К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Печать из внешней обработки

0 - 12.04.2019 - 13:17
Просмотрел сообщения на эту тему, вроде все соответствует
&НаСервере
Функция ПолучитьМакетНаСервере()
ОбработкаОбъект = РеквизитФормыВЗначение("Обработка"); // мы получаем именно объект
Макет = ОбработкаОбъект.ПолучитьМакет("Макет1");
Возврат Макет;
КонецФункции

&НаКлиенте
Процедура Печать()
Макет=ПолучитьМакетНаСервере();
ТабДок = Новый ТабличныйДокумент;
ТабДок.Вывести(Макет);
ТабДок.Показать();
КонецПроцедуры
&НаКлиенте
Процедура ПриОткрытии(Отказ)
КонецПроцедуры

&НаКлиенте
Процедура НалогиИВзносы()

Печать();
// Вставить содержимое обработчика.
КонецПроцедуры


При нажатии на кнопку НалогиИВзносы
Недопстимое значение параметра(параметр № "1")

Спасибо!



1 - 12.04.2019 - 13:46
(0) Это должна быть команда.
И в модуле выглядеть так:
Процедура НалогиИВзносы(Команда)
2 - 12.04.2019 - 15:25
И была команда, в процедуре поставил в скобках (Команда)
3 - 12.04.2019 - 15:26
Та же диагностика
4 - 12.04.2019 - 15:27
ЗУП поставил последнюю 8.3.14.
5 - 12.04.2019 - 15:37
из пофигуратора запустить 1с в режиме отладки (F5)
открыть обработку
нажать на кнопку
появится окно с ошибкой
нажать кнопку "подробно..."
прочитать описание ошибки и понять где она возникает
6 - 12.04.2019 - 15:41
ОбработкаОбъект = РеквизитФормыВЗначение("Обработка"); // мы получаем именно объект
по причине:
Недопустимое значение параметра (параметр номер '1')
7 - 12.04.2019 - 15:58
"Обработка" - недопустимое значение параметра, надо другое значение)
8 - 12.04.2019 - 16:05
+ обычно это "Объект"...
9 - 12.04.2019 - 16:10
и с "Объект" та же ошибка, когда по сети искал, правили(у кого-то), пока не пришли к исходному (моему) виду и все заработало, а я что-то где-то недоучел
10 - 12.04.2019 - 16:21
реквизит с именем "обработка" у формы есть? какой у него тип?
11 - 12.04.2019 - 16:38
Такого реквизита нет, а какой тип у него поставить, просто добавить и никуда не подцеплять?
В модуле форме функция "Сведения о внешней обработке" есть.
12 - 12.04.2019 - 17:10
не, тут все проще... надо взять все книжки "жкк" и усердно читать
13 - 12.04.2019 - 17:23
Понял, спасибо! Пошел читать.
14 - 12.04.2019 - 17:34
У Вас же есть реквизит формы с типом ВнешняяОбработка, вот его и превращайте а объект, из которого потом получите искомый макет.
15 - 15.04.2019 - 13:23
14) Спасибо! Получилось!!!


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены