К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Ошибка в 1С:Бух77 ред.533 Начисление ФФОМС при ЕНВД ?

Гость
0 - 03.02.2012 - 05:53
Вопрос-Это в ошибка?. Как правильно её обойти?
----------------------------------------------
Ошибка в 1С:Бух77 ред.533 Начисление ФФОМС при ЕНВД

При начислении налогов с ФОТ (док.ЗакрытиеМесяца) не расчитываются налоги ФФОМС, если начисление зарплаты проводится как "облагаемые ЕНВД".
---------------------------------
Ошибка возникает по причине того, что расчет ставки налога ФФОМС и ТФОМС идут следом друг за другом и вычисленная ставка налога для ФФОМС затирается затем ставкой налога для ТФОМС (которая в этом году равна 0%)

Для исправления этой ситуации было добавлено пару строк в модуль документа "ЗакрытиеМесяца".

со строки № 7254

было:

Если РезультатФФОМС <> 0 Тогда
ТаблицаРаспределения = РаспределитьВзносыПоНачислениям(РезультатФФОМС, НачисленияФОМС, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);
ТаблицаРаспределения.ВыбратьСтроки();
Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл
СформироватьПроводку("ФФОМС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);
СформироватьПроводкуСВЗ("ФФОМС", Сотрудник, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);
КонецЦикла;
КонецЕсли;

стало:

Если РезультатФФОМС <> 0 Тогда
ИмяШкалыВзносов = "ФФОМС"; //добавлено LB2012
СтавкаТарифа = глПолучитьСтавкуВзноса(ВидТарифа,ИмяШкалыВзносов,Д атаКон) / 100; //добавлено LB2012

ТаблицаРаспределения = РаспределитьВзносыПоНачислениям(РезультатФФОМС, НачисленияФОМС, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);
ТаблицаРаспределения.ВыбратьСтроки();
Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл
СформироватьПроводку("ФФОМС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);
СформироватьПроводкуСВЗ("ФФОМС", Сотрудник, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);
КонецЦикла;
КонецЕсли;

------

и со строки №7263

было:

Если РезультатТФОМС <> 0 Тогда

ТаблицаРаспределения = РаспределитьВзносыПоНачислениям(РезультатТФОМС, НачисленияФОМС, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);

ТаблицаРаспределения.ВыбратьСтроки();

Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 ЦиклСформироватьПроводку("ТФОМС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);

СформироватьПроводкуСВЗ("ТФОМС", Сотрудник, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);

КонецЦикла;

КонецЕсли;


стало:

Если РезультатТФОМС <> 0 Тогда

ИмяШкалыВзносов = "ТФОМС";//добавлено LB2012

СтавкаТарифа = глПолучитьСтавкуВзноса(ВидТарифа,ИмяШкалыВзносов,Д атаКон) / 100;//добавлено LB2012

ТаблицаРаспределения = РаспределитьВзносыПоНачислениям(РезультатТФОМС, НачисленияФОМС, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);

ТаблицаРаспределения.ВыбратьСтроки();

Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 ЦиклСформироватьПроводку("ТФОМС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);

СформироватьПроводкуСВЗ("ТФОМС", Сотрудник, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);

КонецЦикла;

КонецЕсли;



1 - 03.02.2012 - 06:09
Вообще-то, 535 актуальный релиз. А не это старье (533).
Гость
2 - 10.02.2012 - 10:26
вообще то 536


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены