К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Описание типов данных

Гость
0 - 16.03.2018 - 12:30
Подскажите плиз, как определить тип данных типа число.

Изначально пишу
ОписаниеЧисла = Новый ОписаниеТипов("Число");
ОписаниеСтроки = Новый ОписаниеТипов("Строка");

потом перебираю реквизиты
ДокРеквизиты = Метаданные.Документы[видДок];
Для каждого Реквизит Из ДокРеквизиты.Реквизиты Цикл
знач_="";
Если Реквизит.Тип=ОписаниеСтроки Тогда
эта ветка отрабатывает
ИначеЕсли Реквизит.Тип=ОписаниеЧисла Тогда
а эта ветка НЕ отрабатывает
в чём причина???



1 - 16.03.2018 - 13:05
Так встань дебагером и посмотри чем твоё описание типов отличается от описания типов в метаданных: оно же не только тип (точнее, массив типов) содержит, но ещё и квалификаторы.
2 - 16.03.2018 - 13:17
(0)
ДокРеквизиты = Метаданные.Документы[видДок].Реквизиты;
Для каждого Реквизит Из ДокРеквизиты Цикл
ТипыРеквизита = Реквизит.Тип.Типы(); // бывают составные типы...
Для каждого Тип Из ТипыРеквизита Цикл
Если Тип=Тип("Строка") Тогда
ИначеЕсли Тип=Тип("Число") Тогда
КонецЕсли;
КонецЦикла;
КонецЦикла;
Гость
3 - 16.03.2018 - 18:38
(2) идеально! Получилось! Спасибо!


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены