К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

ОФФ работает под windows 7 и не работает под xp

Гость
0 - 20.05.2015 - 10:58
пробую выполнить такой скрипт

var WinHttp = new ActiveXObject("WinHttp.WinHttpRequest.5.1");

WinHttp.Open("POST", "https://github.com/index.html", false);

var data = '';

WinHttp.Send(data);

работает под windows 7 и не работает под xp, выдает ошибку в длл WinHttp

'80090326'

The message received was unexpected or badly formatted.


кто знает как сделать чтобы заработало под xp?



101
1 - 20.05.2015 - 11:15
http://1c-programmer-blog.ru/program...tream-ado.html
101
2 - 20.05.2015 - 11:21
http://forum.infostart.ru/forum26/topic52177/
до кучи
3 - 20.05.2015 - 11:49
(0)
никак, хр не поддерживает TLS версии старше 1.0
Гость
4 - 20.05.2015 - 12:15
(1) понятно, есть куча кода которую надо заставить работать, это не подходит.
(2) под xp работает?
(3) интересно, щас попробую поискать что это означает. если можешь напиши подробнее
5 - 20.05.2015 - 12:45
(4)
https://community.constantcontact.co...ed/td-p/258533
что-то типа того...
Гость
6 - 20.05.2015 - 13:51
(5) спасибо,
раз soapui соединяется он видимо использует tls подходящей версии. не знаешь как из скрипта js установить что я хочу использовать например tls 1.0?
7 - 20.05.2015 - 14:16
(6)
soapui на хр с чем соединяется?
Гость
8 - 20.05.2015 - 14:26
(7) фактически есть испанский сервер с вебсервисом, с которым и надо соединиться
9 - 20.05.2015 - 14:28
(8)
если под хр соединяется, значит на том сервере tls 1.0 поддерживается
Гость
10 - 20.05.2015 - 14:30
(9) а winhttp сам должен согласовать версию с сервером или её надо указывать?
Гость
11 - 20.05.2015 - 14:39
10-angro > Посмотри http://evgalt.livejournal.com/26099.html
12 - 20.05.2015 - 15:00
(10)
хм... винхттп 5.1 только тлс 1.0 и держит, судя по доке) проверь на хп в настройках обозревателя - дополнительно - безопасность - стоит ли галка на тлс 1.0
Гость
13 - 20.05.2015 - 15:06
(12) стоит. интересно может соап иметь свою библиотеку для тлс 1.1 или 1.2
Гость
14 - 20.05.2015 - 15:06
+13 он же на джаве, вполне вероятно, надо доки почитать
15 - 20.05.2015 - 15:10
(13)
это на уровне ядра ос хр, если бы имел свою библиотеку - соединялся бы...
Гость
16 - 20.05.2015 - 15:13
(15) так соап как раз соединяется
а tls 1.2 судя по интернету встроен в java 8.

сейчас попрошу проверить, но у них сиеста, так что [*****] :)
Гость
17 - 20.05.2015 - 15:14
интересно почему слово м а н ь я н а движок запикал?
18 - 20.05.2015 - 15:20
(16)
это вполне вероятно, что последняя жаба держит tls 1.2
лучше попроси у мучачос, чтоб они для тебя tls 1.0 включили :D


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены