К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Обработка заполнения ТЧ для интерфейса Такси

Гость
0 - 05.06.2014 - 09:30
Пожалуйста скиньте внешнюю обработку или кусок кода по заполнению табличной части документа в новом интерфейсе Такси (БП 3.0.33.15 и выше). Старый способ с открытием формы модально теперь выдает предупреждение.
Я про вариант, когда в обработке есть своя форма в которой нужно что-то делать до заполнения ТЧ исходного документа.



Uho
1 - 05.06.2014 - 09:46
так не открывай модально
Гость
2 - 05.06.2014 - 11:52
Пробовал не получается. Нужен рабочий вариант или пример.
Гость
3 - 05.06.2014 - 12:54
Вообще-то, проблемы с модальными окнами - давние. Что-то не срастается у 1С с MS.
2-aab >"в обработке есть своя форма в которой нужно что-то делать до заполнения ТЧ исходного документа" - а поподробнее про это "что-то" никак низзя? "Нетленка", после которой вербовщики из Microsoft и Apple устроят драку в прихожей?
Гость
4 - 05.06.2014 - 19:56
3-VZ > Это не MS:
http://v8.1c.ru/o7/201301nm/
Гость
5 - 06.06.2014 - 07:43
3-VZ > Да вариантов масса, что нужно вводить до заполнения табличной части. Это может быть, например, сотрудник, чтобы вывести остатки по нему. Или таблица какая-нибудь для разбивки поступления по разным подразделениям.
Гость
6 - 06.06.2014 - 07:50
4-Reaper> Читал я эту статью, не понравилось, что придётся параметры несколько раз передавать, коряво это как-то, думал есть какой-то более правильный вариант.
Вот кусок кода, который нормально работал до Такси:

&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначенияМассив) Экспорт

КлючПоиска = Новый Структура("Ключ", ОбъектыНазначенияМассив[0]);
Окна = ПолучитьОкна();
Для каждого Окно из Окна Цикл
Если НЕ Окно.Основное И Найти(Окно.Заголовок, ОбъектыНазначенияМассив[0]) Тогда

ИмяФормыДокументаРеализации = Окно.ПолучитьСодержимое().ИмяФормы;

Форма = ОткрытьФорму(ИмяФормыДокументаРеализации,КлючПоиск а);
ДокументОбъект = Форма.Объект;

ВыбраннаяФорма = ОткрытьФормуМодально(ЭтаФорма);

Если ВыбраннаяФорма = Неопределено тогда
Продолжить;
КонецЕсли;

Если Вопрос("Табличная часть документа будет очищена! Продолжить?",РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Да тогда
ЗаполнитьОбъект(ДокументОбъект);
КопироватьДанныеФормы(ДокументОбъект, Форма.Объект);
Форма.Модифицированность = Истина;
Иначе
Возврат;
КонецЕсли;
КонецЕсли;
КонецЦикла;

КонецПроцедуры


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены