К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Обновитление формы документа после заполнения ТЧ

Гость
0 - 13.08.2013 - 15:27
Для конфигурации УТ 11 (11.1.2.8) написана обработка ТЧ документа, после изменения ТЧ документа, используется Оповестить("ОбновитьДокументИБПослеЗаполнения"), работает только для документа "Заказ клиента", формы других документов не обновляются, УТ 11.1.2.8, в чем может быть причина?


Uho
1 - 13.08.2013 - 16:13
ну а обработка то оповещения у других документов есть?
Гость
2 - 13.08.2013 - 16:19
да уже нашел что у этих документов нет обрабтки события "ОбновитьДокументИБПослеЗаполнения", как тогда делать только через открытие-закрытие формы, если без изменения конфигурации
Uho
3 - 13.08.2013 - 16:58
а чё, в УТ нет стандартного механизма заполнения ТЧ из внешней обработки?
Гость
4 - 13.08.2013 - 17:08
внешняя обработка меняет строки документа (объекта) после этого нужно обновить форму документа, разговор идет об управляемых формах
Uho
5 - 13.08.2013 - 17:34
ОповеститьОбИзменении() не?
Гость
6 - 13.08.2013 - 18:20
5-Uho > можешь привести пример кода
Гость
7 - 13.08.2013 - 18:21
вот код процедуры Обработка оповещения документа Реализации, конфигурацию не изменяем
Гость
8 - 13.08.2013 - 18:22
// Подсистема "Свойства"
Если УправлениеСвойствамиКлиент.ОбрабатыватьОповещения( ЭтаФорма, ИмяСобытия, Параметр) Тогда
ОбновитьЭлементыДополнительныхРеквизитов();
КонецЕсли;

// ПодключаемоеОборудование
Если Источник = "ПодключаемоеОборудование" И ВводДоступен() Тогда
Если ИмяСобытия = "ScanData" Тогда
ОбработатьШтрихкоды(МенеджерОборудованияКлиент.Пре образоватьДанныеСоСканераВМассив(Параметр));
КонецЕсли;
КонецЕсли;
// Конец ПодключаемоеОборудование

// Неизвестные штрихкоды
Если Источник = "ПодключаемоеОборудование"
И ИмяСобытия = "НеизвестныеШтрихкоды"
И Параметр.ФормаВладелец = УникальныйИдентификатор Тогда

КэшированныеЗначения.Штрихкоды.Очистить();
ДанныеШтрихкодов = Новый Массив;
Для Каждого ПолученныйШтрихкод Из Параметр.ПолученыНовыеШтрихкоды Цикл
ДанныеШтрихкодов.Добавить(ПолученныйШтрихкод);
КонецЦикла;
Для Каждого ПолученныйШтрихкод Из Параметр.ЗарегистрированныеШтрихкоды Цикл
ДанныеШтрихкодов.Добавить(ПолученныйШтрихкод);
КонецЦикла;

ОбработатьШтрихкоды(ДанныеШтрихкодов);

КонецЕсли;

Если ИмяСобытия = "ЗачтенаОплата" И Параметр = Объект.Ссылка Тогда
ЗачтенаОплатаСервер();
КонецЕсли;

// Подсистема "ЭлектронныеДокументы"
Если ИмяСобытия = "ОбновитьСостояниеЭД" Тогда
УстановитьТекстСостоянияЭДНаСервере();
КонецЕсли;

Если ИмяСобытия = "СчитанаКартаЛояльности"
И Параметр.ФормаВладелец = УникальныйИдентификатор Тогда
СчитанаКартаЛояльности(Параметр.КартаЛояльности);
КонецЕсли;

Если ИмяСобытия = "ПолученыСообщения"
И Параметр.ФормаВладелец = УникальныйИдентификатор Тогда
ПолученыСообщения(Параметр.Сообщения);
КонецЕсли;

Если ИмяСобытия = "ИзмененРеквизитЗависящийОтСтатуса"
И Параметр.УникальныйИдентификатор = УникальныйИдентификатор Тогда
Если Объект.Согласован Тогда
Объект.Согласован = Ложь;
КонецЕсли;
ПодключитьОбработчикОжидания("Подключаемый_ПриИзме ненииРеквизитаЗависящегоОтСтатуса", 0.1, Истина);
КонецЕсли;

Если ИмяСобытия = "КопированиеСтрокВБуферОбмена" Тогда

УстановитьДоступностьКомандБуфераОбменаНаКлиенте() ;

КонецЕсли;
Гость
9 - 13.08.2013 - 18:23
не вижу здесь обновления данных формы документа
Гость
10 - 13.08.2013 - 21:57
Не туда смотришь. Подсистема дополнительных обработок, вызов дополнительной назначаемой обработки вида "обработка заполнения объекта" система заканчивает обновлением данных формы, из которой обработка была запущена.
Гость
11 - 14.08.2013 - 07:01
"ОбработкаПроверкиЗаполненияНаСервере" ? Для документа Реализация она тоже не заполнена
Гость
12 - 14.08.2013 - 07:05
http://goo.gl/6U4y7N
Гость
13 - 14.08.2013 - 07:43
12-Reaper > спасибо )), но у меня доступа нет )


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены