К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Обход группировок запроса

Гость
0 - 23.09.2012 - 21:02
Напоролся недавно.
Обход двух группировок запроса.
...
Пока Запрос.Группировка(1) Цикл
Пока Запрос.Группировка(2) Цикл
...
Если (Условие) Тогда
// Ну вот надо прервать
Прервать;
КонецЕсли;

КонецЦикла;
КонецЦикла;

Как только для какого-то значения группировки 1 условие выполнилось и произошло
прерывание второго цикла, то для следующего
значения группировки 1 второй цикл (по значениям группировки 2) совсем не выполняется. Если не прерывать, то все нормально.
Это че - баг или фича ?



Гость
1 - 23.09.2012 - 22:00
мануалы читай, бестолочь.
Гость
2 - 23.09.2012 - 22:02
"Описание встроенного языка".
Глава 33, в выводах к примеру в самом начале главы.
"не следует прерывать последовательность просмотра временного набора данных (например, оператором Прервать;), если вы собираетесь использовать временный набор дальше или еще раз, т. к. в таком случае теряется точка позиционирования во временном наборе и продолжать просмотр невозможно"
Гость
3 - 23.09.2012 - 22:51
2-Cthulhu >Таки фича
Гость
4 - 24.09.2012 - 00:23
(2): замени "прервать" на "продолжить", делов то.
5 - 24.09.2012 - 10:41
4-Cthulhu > Может противоречить смыслу задачи онако
Гость
6 - 24.09.2012 - 11:07
5-roma n > Ему надо прервать второй цикл (который вложенные), тут по смыслу даже удобнее - "продолжить выполнение первого цикла - второй продолжать дальше не надо"


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены