К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

О сколько нам открытий чудных готовят дятлы 1С...

Гость
0 - 03.02.2012 - 08:25
Бояню, нет?

Если ((ПустоеЗначение(ДатаНомерСчетаФактуры) = 1) и (Выбран() = 1))
или (((ПустоеЗначение(ДатаСчетаФактуры) = 1) или (ПустоеЗначение(НомерСчетаФактуры) = 1)) и (Выбран() = 1)) Тогда
СчетФактураПредъявлен = 0;


У меня только один вопрос - ну сколько можно-то, а???



Гость
41 - 04.02.2012 - 21:16
Одноэсники пишут код идиотов - лишний и пустой

Процедура Показать_()
Если Показать=1 Тогда
Форма.ДатаНомерСчетаФактуры.Видимость(1);
Форма.ДатаСчетаФактуры.Видимость(0);
Форма.НомерСчетаФактуры.Видимость(0);
Иначе
Форма.ДатаНомерСчетаФактуры.Видимость(0);
Форма.ДатаСчетаФактуры.Видимость(1);
Форма.НомерСчетаФактуры.Видимость(1);
КонецЕсли;
КонецПроцедуры


Процедура Показать_()
Форма.ДатаНомерСчетаФактуры.Видимость(Показать);
Форма.ДатаСчетаФактуры.Видимость(1-Показать);
Форма.НомерСчетаФактуры.Видимость(1-Показать);
КонецПроцедуры

наверное и далее код можно переписать проще и понятнее.
а потом оне тут хвалятся, у кого конфига толще
42 - 04.02.2012 - 21:34
Цитата:
Сообщение от Helen 1986 Посмотреть сообщение
а потом оне тут хвалятся, у кого конфига толще
А если оплата, как у журналистав, от количества печатных знаков?
Гость
43 - 04.02.2012 - 21:38
заказчик - дебилоид?
Гость
44 - 04.02.2012 - 21:39
45 - 05.02.2012 - 01:40
Типовые конфиги - зло!
писать надо то, что заказчику нужно по ТЗ, используя, м.б, что-то БСП.
тогда за каждую ашипку будет понятно с кого спрашивать - с заказчегов или с исполнителей.
а так как нормальных ТЗ - хрен кто напишет - то при жевании типовых 1С - нехай жуют 1С аз из, а исправление выявленных ашипак - отдельно за большую оплату.
а обучение работе на типовых конфигах - ЕСЛИ ОНО НАДО - ваще за бешеные бапки.
как-тотак...
46 - 05.02.2012 - 09:32
41-Helen 1986 > Молодца! :-)


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены