К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Некорректно отображается «РегистрБухгалтерииСписок»

Гость
0 - 17.03.2013 - 16:50
Есть ТабличноеПоле1 в нем отображается список документов «Приход товара». Хочу сделать так что бы в ТабличноеПоле2 отображались для выбранного в ТабличноеПоле1 документа его движения по одному из регистров. По какому конкретно регистру отображать движения в ТабличноеПоле2 определяется Переключателем (выбирается один из трех возможных регистров).

Вот код:

Процедура ТоварныеЗапасыПриИзменении(Элемент = "")
Если Переключатель = "ТоварныеЗапасы" Тогда
ЭлементыФормы.ТабличноеПоле2.ТипЗначения = Новый ОписаниеТипов("РегистрНакопленияСписок.ТоварныеЗап асы");
ИначеЕсли Переключатель = "Взаиморасчеты" Тогда
ЭлементыФормы.ТабличноеПоле2.ТипЗначения = Новый ОписаниеТипов("РегистрНакопленияСписок.Взаиморасче ты");
Иначе
ЭлементыФормы.ТабличноеПоле2.ТипЗначения = Новый ОписаниеТипов("РегистрБухгалтерииСписок.Управленче ский");
КонецЕсли;

ЭлементыФормы.ТабличноеПоле2.СоздатьКолонки();

ТабличноеПоле1ПриАктивизацииСтроки(ЭлементыФормы.Т абличноеПоле1);
КонецПроцедуры

Процедура ПриОткрытии()
Переключатель = "ТоварныеЗапасы";
ТоварныеЗапасыПриИзменении();
КонецПроцедуры

Процедура ТабличноеПоле1ПриАктивизацииСтроки(Элемент)
ЭлементыФормы.ТабличноеПоле2.Значение.Отбор.Регист ратор.Установить(Элемент.ТекущаяСтрока);
КонецПроцедуры

В результате - движения по двум регистрам накопления отображаются корректно, а движения по регистру бухгалтерии НЕ корректно. Почему-то многократно отображается одна и та же строка и при этом не показываются субконто. Вот скриншот: http://s020.radikal.ru/i722/1303/7a/52dace14568f.jpg

Кому интересно, конфигурацию можно скачать здесь: http://www.fayloobmennik.net/2705983
В конфигурации смотри «Обработка1».

Подскажите в чем косяк?





К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены