К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

&НаСервере сколько вызовов?

0 - 13.04.2012 - 15:02
Что-то я вконец запутался.
Есть код типа:

&НаСервереБезКонтекста
Процедура В()
// что-то делает
КонецПроцедуры

&НаСервереБезКонтекста
Процедура Б()
В();
КонецПроцедуры

&НаКлиенте
Процедура А()
Б();
КонецПроцедуры

Меня тут сидят и путают, мол при обращении из процедуры Б к процедуре В создается дополнительный вызов серевера и все будет сильно тормозить... Я уже начал сомневаться... так это или нет... ЖКК под рукой, увы нет...



Гость
1 - 13.04.2012 - 15:11
(0) Врут.
Uho
2 - 13.04.2012 - 15:13
0-bma1 > чем аргументируют?
3 - 13.04.2012 - 15:19
2(2) Мол раз это написано в модуле формы, она "по умолчанию" имеет контекст НаКлиенте и каждый раз вызов процедур из модуля формы на сервер будет запрашиваться с формы, даже если из процедуры с директивой НАСервере... я уже запутался...
4 - 13.04.2012 - 15:22
P.S. т.е. рисуют мне схемку, мол вызов из контества сервер сперва идет на клиента а оттуда снова на сервер...
Uho
5 - 13.04.2012 - 15:30
(3) вообще-то, модуль формы не имеет определенного контекста
Гость
6 - 13.04.2012 - 15:30
(4) Бей схемой по голове, пока не сотрется вызов клиента со стороны сервера.
Гость
7 - 13.04.2012 - 21:42
включи "Отображать параметры производительности", да посмотри
8 - 14.04.2012 - 15:33
2(7) "Умная мысля всегда приходит опосля" Вчера, из-за вечерней пятничной запарки (у всех появились срочные дела ко мне сразу после 15:00) просто не успел вспомнить о такой возможности...


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены