К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Напомните плиз как там слипом тормознуть модуль на пяток секунд

Гость
0 - 18.04.2012 - 10:38
собственно сабж


Гость
1 - 18.04.2012 - 11:03
оСистема = СоздатьОбъект("Система");
оСистема.Sleep(5000);
Uho
2 - 18.04.2012 - 11:13
а че гетперформанскаунтер уже не работает?
Гость
3 - 18.04.2012 - 11:21
Да мне в 7.7 . Через Wscript
Гость
4 - 18.04.2012 - 11:25
3-drums2004 > и я про 7.7
Uho
5 - 18.04.2012 - 11:40
и даже я про 7.7
Гость
6 - 18.04.2012 - 11:40
Издеваемся ? Нет там такого объекта и не было никогда .
Uho
7 - 18.04.2012 - 11:44
(6) _getPerformanceCounter()
Гость
8 - 18.04.2012 - 11:44
6-drums2004 > Ну-ну.
Процедура ВыбратьКатегориюЦенИзДругойБазы()
Перем идКатЦен, Представление, н;

Если ТипЗначенияСтр(сзКатЦенИзДругойБазы) <> "СписокЗначений" Тогда
Если ЗапроситьКатегорииЦенИзДругойБазы() = 0 Тогда
Возврат;
КонецЕсли;
ОбъектП.ОткрытьОкноСообщения("Ожидание ответа");
оСистема = СоздатьОбъект("Система");
Пока ТипЗначенияСтр(сзКатЦенИзДругойБазы) <> "СписокЗначений" Цикл
оСистема.Sleep(100);
КонецЦикла;
КонецЕсли;
ОбъектП.ЗакрытьОкноСообщения();

Если ТипЗначенияСтр(сзКатЦенИзДругойБазы) <> "СписокЗначений" Тогда
Возврат;
КонецЕсли;

идКатЦен = тзКатегорииЦен.идКатегорияВДругойБазе;
н = сзКатЦенИзДругойБазы.НайтиЗначение(идКатЦен);
Если сзКатЦенИзДругойБазы.ВыбратьЗначение(идКатЦен, "Категория цен", н,, 0) = 0 Тогда
Возврат;
КонецЕсли;

сзКатЦенИзДругойБазы.ПолучитьЗначение(н, Представление);

тзКатегорииЦен.идКатегорияВДругойБазе = идКатЦен;
тзКатегорииЦен.КатегорияВДругойБазе = Представление;
КонецПроцедуры
Гость
9 - 18.04.2012 - 11:55
Это у вас ВК какая-то стоит . Нету в семерке обьектов таких .
Гость
10 - 18.04.2012 - 11:58
9-drums2004 > ВК какая-то стоит - разумеется. 1С++ называется. А у вас ее, разве, до сих пор нету?
Гость
11 - 18.04.2012 - 12:04
Нет . И ставить на 15 баз нет желания .Я спрашивал как через WScript тормознуть
Гость
12 - 18.04.2012 - 12:08
а зачем скрипт, просто предупреждение на 5 секунд не?
Гость
13 - 18.04.2012 - 12:12
11-drums2004 > И ставить на 15 баз нет желания - безумно сложное занятие - копировать файлик, ага.
Uho
14 - 18.04.2012 - 12:24
9-drums2004 > http://g.zeos.in/?q=_getPerformanceCounter()
Гость
15 - 18.04.2012 - 12:56
http://help1c.com/faq/view/584.html


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены