К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

НайтиСсылки() - можно использовать в контексте формы документа?

Гость
0 - 13.03.2015 - 11:29
7.7. ОУ, релиз 023
Прилепил кнопочку, прописал процедуру и вот:

НайтиСсылки(<<?>>Товар,Тз);
{Документ.УдалениеТоваров.Форма.Модуль(11)**: Слишком много фактических параметров

Это пятница сегодня такая или я что-то пропустил в этой жизни?



1 - 13.03.2015 - 11:58
"Это пятница сегодня такая или я что-то пропустил в этой жизни?" - второе...

так в модуле формы дока писать НЕ НАДО
Процедура НайтиСсылки()
НайтиСсылки(Товар,Тз);
КонецПроцедуры
101
2 - 13.03.2015 - 11:59
НайтиСсылки(??? товар эточойта ?
Гость
3 - 13.03.2015 - 12:00
Сообщение ругается на Товар. Значит, в параметрах - недопустимый тип значения.

И почему релиз 023? А не отлаженный 27?
Гость
4 - 13.03.2015 - 12:03
Всем по порядку...
1) Вот так все и написано:
Процедура НайтиСсылки()
ТЗ=СоздатьОбъект("ТаблицаЗначений");
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 цикл
НайтиСсылки(ТоварПред,Тз);
СсылкиПред=Тз.КоличествоСтрок();
Спр.НайтиЭлемент(ТоварТек);

СсылкиТек=Тз.КоличествоСтрок();
КонецЦикла;
КонецПроцедуры
Гость
5 - 13.03.2015 - 12:04
Блин...каша какая...это я Таб нажал...
Гость
6 - 13.03.2015 - 12:05
Вот, процедура
Процедура НайтиСсылки()
ТЗ=СоздатьОбъект("ТаблицаЗначений");
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 цикл
НайтиСсылки(Товар,Тз);
КонецЦикла;
КонецПроцедуры
Гость
7 - 13.03.2015 - 12:06
2) Ругается не при выполнении а проверке синтаксиса...
Гость
8 - 13.03.2015 - 12:07
3) Товар в параметре - это значение, типа, справочник
9 - 13.03.2015 - 12:19
(4-6)
прочти в (1) выделенное жирным и подчеркнутое, раз 50...
Гость
10 - 13.03.2015 - 12:21
А как надо?
Гость
11 - 13.03.2015 - 12:22
Ты бы еще двоеточие поставил....чтобы понятнее было к чему твое "не надо" относится...
12 - 13.03.2015 - 12:29
(10)
глаз конкретно замылился?))
надо так:
Процедура ИмяПроцедурыОтличающеесяОт_НайтиСсылки_()
НайтиСсылки(Товар,Тз);
КонецПроцедуры
Гость
13 - 13.03.2015 - 12:32
Хоспадя, воля твоя...
СписокТоваров=СоздатьОбъект("СписокЗначений");
ВыбратьСтроки();
Пока ПолучитьСтроку()=2 Цикл
СписокТоваров.Установить(Строка(Товар.ПолныйКод()+ " "+Товар.Наименование),Товар);
КонецЦикла:
Если СписокТовара.РазмерСписка()=0 Тогда
сообщить("Пшол [*****], оборванец");
Иначе
НайтиСсылки(СписокТоваров,ТЗ);
КонецЕсли;
101
14 - 13.03.2015 - 12:40
никто не задумался почему документ называется удалениетоваров ;))) и зачем там найти ссык... тьпу ссылки ;)))
Гость
15 - 13.03.2015 - 12:41
12))))) Ну, блин!!! Я же говорил ПЯТНИЦА сегодня такая...
Спасибо тебе добрый человек - пользователь 1С
А то я почти совсем уже веру в торжество разума потерял...
Гость
16 - 13.03.2015 - 12:44
+13 P.S. 1.По хорошему, надо еще проверять полноту строк на ПустоеЗначение(Товар) (оператору доверия нет!).
2. Заместо Строка(Товар.ПолныйКод()+ " "+Товар.Наименование) кошернее юзать ЗначениеВСтрокуВнутр(Товар)
101
17 - 13.03.2015 - 12:48
(16) выбран - аналогично имхо по скорости будет ...
101
18 - 13.03.2015 - 12:51
(17)+ имелось ввиду любую проверку, кроме пустоезначение ... (оно конешно быстрее чем выбран но ... ничонискажет если ссылка осталась а товара нет)
Гость
19 - 13.03.2015 - 12:51
16) Спасибо VZ - обязательно буду проверять...
Гость
20 - 13.03.2015 - 12:55
17-101 > Это не важно ;)
Что важно: ТС почему-то считает, что его ТЗ будет дополняться при пробежки по строкам (на самом деле - формировться по новому). Наверно, думает что разработчики платформы угадали его желания ;)
ТС не учитывает, что строки могут содержать одинаковые значения.

И вообще я не доверяю тем, кто использует древний релиз.
101
21 - 13.03.2015 - 13:16
(20) ну если он потом перевыгружает ссылки в новую ТЗ - то почему бы и нет ... хотя хз, мну ваще обескуражен самой идеей , хотя некое зерно в данном случае есть - типа сохранить все данные в текстовом виде в документе а сам товар удалить ... но МлийАА зачем ??? или еще и из ссылок его убацать ? намертво ? ну как бы для истории что ли ? ну и нафек такая история без ссылок ??? нипанимаю - если только один товар заменяется на некий обезличенный для схлопывания истории , ну ладно, а с регистрами чоу делать ?
ЗЫ понимаю когда например прайсовую позицию меняют ... ну там да - история логична , она не основа ...
Гость
22 - 13.03.2015 - 13:35
Документ собирает товар с одинаковыми наименованиями и дает данные по их остаткам, количеству ссылок на них, ценах, датах последнего поступления и т.д. После заполнения менеджер выбирает, какой товар оставить а какой пометить на удаление. При проведении документа убираемый товар заменяется на оставляемый везде, где на него есть ссылки. Такие дела...
Гость
23 - 13.03.2015 - 13:41
22-Opener > Прэлестно...
24 - 13.03.2015 - 14:09
(22)
на заметку в будущем, чтобы избежать подобной ситуации "товар с одинаковыми наименованиями"
номенклатурой в базе должен мочь заниматься один(2,3...) пользователь с правами(в базе) и обязанностями(в должностной инструкции) + со всеми вытекающими карами, когда наступит подобный случай по его вине...
Гость
25 - 13.03.2015 - 14:44
Да, это сделано... и автор нового элемента фиксируется... Тут ситуация немного не стандартная. Товар заносится в базе Опта а потом обработкой перекидывается в базу Розницы. Когда этот товар попал второй раз в Розницу - уже не определить. Базе 10 лет скоро будет. Поэтому и названия одинаковые. Проверил обработку - все нормально. Ну, посмотрим, как он теперь появится в будущем... 8)
101
26 - 13.03.2015 - 15:53
(25) УРБД что ли ? для этого делается ЦЕНТРАЛЬНАЯ база в которую кроме справочников ничо не заводят, или любая другая база в которую только справочники и заводят а в остальные базы - запрет ...
27 - 13.03.2015 - 23:43
(1)+
28 - 13.03.2015 - 23:52
(27)+++
Прроцедура НайтиСсылки() Сообщить("Что-то здесь не так..."); //(с) user1C


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены