К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Надежды мало, но вдруг:

0 - 22.01.2019 - 23:34
Есть обработка, которая через промежуточный файл текстовывй переносит документы из ТИС в БП. Работала себе, работала и вдруг - сбой. Бухи делают в ТИС одинаковые номера для Реализации и СФ выданой, а в БП создается со штатным номером из БП, номером по порядку.
//---------------------------------------------------------
Удален документ Счет-фактура выданный 0000-0000448 от 04.12.2018 16:01:43
Удален документ Реализация (акт, накладная) Р000000215 от 04.12.2018 16:01:43
Записан документ Реализация (акт, накладная) Р000000215 от 04.12.2018 16:01:43
Записан документ Счет-фактура выданный 0000-0000450 от 04.12.2018 16:01:43
//---------------------------------------------------------
Начинаю гонять отладчик - где теряет номер?
Оказывается, номер теряется в модуле документа СФвыданный
Процедура СинхронизироватьРеквизитыОбъекта(ПараметрыСФ, СтрокаРеквизиты)

Реквизиты = СтрРазделить(СтрокаРеквизиты, ",", Ложь);

Для Каждого Реквизит Из Реквизиты Цикл

Если ПараметрыСФ[Реквизит] <> Неопределено
И ПараметрыСФ[Реквизит] <> ЭтотОбъект[Реквизит] Тогда

ЭтотОбъект[Реквизит] = ПараметрыСФ[Реквизит];

Если Реквизит = "Организация" Тогда
Номер = "";
ИначеЕсли Реквизит = "Контрагент" Тогда
КППКонтрагента = "";
КонецЕсли;

КонецЕсли;

КонецЦикла;

КонецПроцедуры



1 - 22.01.2019 - 23:39
Если Реквизит = "Организация" Тогда
Номер = "";

А отладчик показывает:

Вся беда в том, что в файл выгружается только Организация Реализации, в СФ она тупо берется из Реализации.
Итог - Номер становится пусто, а раз пусто - система присваивает новый. А Организация в СФ все равно правльная, и в Реализации тоже.
Вопрос: где поискать следы второй Организации, почистить их?
Uho
2 - 23.01.2019 - 10:53
ну так процедура СинхронизироватьРеквизитыОбъекта вызывается то когда? когда СФ создается на основании? Создавай СФ программно НЕ на основании и не будет эта процедурина вызываться, или номер переприсваивай после
3 - 23.01.2019 - 11:47
2-Uho > Спасибо, утро вечера мудренее, сегодня с утра примерно так и сделал, работает.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены