К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Модифицированность() 7.7

Гость
0 - 09.08.2012 - 11:01
Есть код проверки при печати
Если (Проведен()=0)
Или ((Проведен()=1) И (Модифицированность()=1)) Тогда
Если глПолучитьПолномочие("РазрешитьПечатьНепроведенных Документов") = 0 Тогда
Предупреждение("Недостаточно полномочий для печати непроведенного документа!", 60);
Возврат;
КонецЕсли;
КонецЕсли;

Под собой отрабатывает нормально.
Под другим пользователем(без прав печати непроведенных):
Создаю документ
Подбор товара
Проведение
Печать
Подбор товара
И после этого при печати в отладчике Модифицированность()=0

Туплю уже пол часа.



1 - 09.08.2012 - 11:05
Создаю документ
Подбор товара
Проведение
Печать
Подбор товара
Закрытие формы - выдает запрос на сохранение изменений?
2 - 09.08.2012 - 11:09
в заголовке формы признак модифицированности отображается?
Гость
3 - 09.08.2012 - 11:11
1, 2 нет
Гость
4 - 09.08.2012 - 11:15
3-vovan519 > После подбора товара в документ - документ не модифицирован??? Там в обработке подбора "Записать()" не затесалось?
Гость
5 - 09.08.2012 - 11:23
Почти разобрался.
Похоже на то , что сработало Форма.ТолькоПросмотр(1), только не найду где, но признаки на лицо ins не работает и т.д, но все кнопки в т.ч. "Подбор" работают.
Соответственно вопрос, если Форма.ТолькоПросмотр(1), то после модификации документа Модифицированность() все равно 0
6 - 09.08.2012 - 11:41
(5)
меню сервис - параметры - "режим открытия объектов" сделать "редактирование" вместо "просмотр"
Гость
7 - 09.08.2012 - 15:05
"режим открытия объектов" - "редактирование"

Тут немного отвлекся. Посмотрел в типовой кмплексной тоже самое. Резюмирую.
Если права запрещают редактирование проведенного документа, то после его проведения устанавливается Форма.ТолькоПросмотр(1) (где и как не понятно), не работают изменения количества, добавление строк и т.д., но подбор работает. Соответственно (я так понял из-за ТолькоПросмотр(1)- Модифицированность() всегда 0) Изменения конечно не сохраняются, НО печатать исправленный документ возможно (см алгоритм в 0)
Может что не досмотрел? Ведь глупо в типовой давать печатать фиктивные документы.
Гость
8 - 10.08.2012 - 08:40
1. Так есть такая особенность в типовой? Или у меня что не так?
2. Повесил на кнопку "Провести"
Процедура ПоКнопкеПровести()
Записать();
Провести();
Если Форма.ТолькоПросмотр()=1 Тогда
Форма.кнПодбор.Доступность(0);
и т.д.
Или проще по другому?
Гость
9 - 10.08.2012 - 08:47
8-vovan519 >

Записать();
Если Проведен() <> 1 Тогда
Провести();
КонецЕсли;

Плюс, рулить доступностью не только этой кнопки, но всех остальных. Посмотреть - скорее всего, уже есть процедурка, которая доступностью управляет.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены