К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Код вида операции в СФ

Гость
0 - 16.04.2015 - 17:19
Здравствуйте. Подскажите, есть ли какая-нибудь обработка для заполнения КодВидаОперации в СчетФактуре. В последнем релизе для бухгалтерии 7.7 (7.70.594) нет новых кодов (письмо ФНС от 22-01-15 № ГД-4-3/794). Как их ставить? вручную....это проблема. Может этот вопрос уже поднимался на форуме. Спасибо


101
1 - 17.04.2015 - 09:32
Процедура СформироватьП()
Перем Запрос, ТекстЗапроса, Таб;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//**{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|Обрабатывать НеПомеченныеНаУдаление;
|СчетФактура = Документ.СчетФактураПолученный.ТекущийДокумент;
|Группировка СчетФактура;
|"//****ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;


Д=СоздатьОбъект("Документ.СчетФактураПолученный");

// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
Пока Запрос.Группировка(1) = 1 Цикл


Если Сокрлп(Д.КодВидаОперации)="" тогда

Д.НайтиДокумент(Запрос.СчетФактура);
Д.ВидОперации = Перечисление.ВидыОперацийСчетаФактурыПолученного.П риобретение;

Д.КодВидаОперации = "01";
// Д.Выставлен=1;

Д.Записать();

КонецЕсли;


// Заполнение полей СчетФактура
Таб.ВывестиСекцию("СчетФактура");
КонецЦикла;
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", "");
КонецПроцедуры
101
2 - 17.04.2015 - 09:33
Д.НайтиДокумент(Запрос.СчетФактура);
Если Сокрлп(Д.КодВидаОперации)="" тогда

поминять мистами


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены