К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Книга продаж и 18% НДС?

0 - 23.04.2019 - 16:26
Ситуевина:
Бухгалтерия 7.7 (650 рел.)
Был введен корректировочный с/ф в 2019 (основной с/ф от 2018). Сумма НДС прошла со ставкой 18%.
В запись книги продаж попала с 18% ставкой.
В Книгу продаж попадает в колонку 20%.
Что интересно, в 649-м релизе она попадала в отчет в колонку с 18%.
Смотрю различия в отчете в 649-м и 650-м релизах. Специально внесли дополнение, если с/ф 2019-го года и ставка 18%, то относить к колонке с 20%-й ставкой.
Это они что-то намудрили, или есть какое-то правило на этот счет? Ведь корректировочная с/ф вводится в 2019-м году, но относится к с/ф выставленным ранее, в 2018-м.



1 - 24.04.2019 - 15:31
Это они что-то намудрили. Хотели сделать заплатку, чтобы НДС определять для авансов. Но анализируют ТабОтчета.СчетФактура вместо ТабОтчета.Док. Причем в 649 сделали для счетов-фактур, которые обрабатывали предварительно все, а не в момент проблемы. Потом увидели что забыли документ "ЗаписьКнигиПродаж" - для него сделали заплатку уже в момент проблемы. То что ТабОтчета.СчетФактура может быть корр.сф - нынешний штатный программист ещё не знает. Отпиши на хотлайн, может прозреют.
2 - 24.04.2019 - 15:35
Сляпал вот такую заплатку вместо 1Сной. Но у меня не используют "Формирование записей книги продаж".

Если (Ставка<>20)и(Ставка<>18) Тогда
ТабОтчета_СчетФактура=ТабОтчета.Док;
Если ПустоеЗначение(ТабОтчета_СчетФактура)=0 Тогда
Если Метаданные.Документ(ТабОтчета_СчетФактура.Вид()).Р еквизитТабличнойЧасти("СтавкаНДС").Выбран()=1 Тогда
ТабОтчета_СчетФактура.ВыбратьСтроки();
Пока ТабОтчета_СчетФактура.ПолучитьСтроку()=1 Цикл
Если ТабОтчета_СчетФактура.СтавкаНДС.Ставка > 10.5 Тогда
Ставка = ТабОтчета_СчетФактура.СтавкаНДС.Ставка;
Прервать;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЕсли;
КонецЕсли;
3 - 24.04.2019 - 17:20
(2) Я решил тупо откатить на 649-й релиз.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены