К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Как заполнять табличную часть документа

Гость
0 - 20.03.2012 - 16:03
При вводе новой строки в табличную с часть, появляется справочник, из него выбирается элемент. Заполянется одна колонка в табличной части - название, а как заполнить остальные колонки, необходимые данные в том же справочнике есть.


Uho
1 - 20.03.2012 - 16:04
должность?
2 - 20.03.2012 - 18:58
2(0) обычай требует сперва спросить пол, а потом потребовать фото топлесс... если пол = блондинка.
Гость
3 - 20.03.2012 - 19:54
3-bma1 >девушка, причём блондинка!;-)
Гость
4 - 20.03.2012 - 20:48
все кухарки умеют управлять гасударством и
пейсать отчеты в 1це предприятии
Гость
5 - 21.03.2012 - 07:50
вот!

Процедура ТаблицаДанныхПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
Если НоваяСтрока Или Копирование Тогда
Элемент.ТекущиеДанные.КакойТоРеквизит = КакоеТоЗначение;
КонецЕсли;
КонецПроцедуры;
Гость
6 - 21.03.2012 - 08:29
хотя нет, так не получается
Гость
7 - 21.03.2012 - 09:06
вот есть такой пример:

Процедура Пересчет(ИмяРеквизита="")

Если ИмяРеквизита = "" Тогда // вызов из формулы колонки табличной части
ИмяРеквизита = Форма.ТекущаяКолонка();
КонецЕсли;

Если Работа.Выбран() = 1 Тогда
Если (ИмяРеквизита = "Работа") Тогда
Цена = глПолучитьЦену(Контекст,Работа,ТипЦен,ДатаДок,?(До говор.Выбран() = 0,"",Договор.ВалютаДоговора),Курс);
Если Количество <> 0 Тогда
Пересчет("Цена")
КонецЕсли;

но вн ем не понятно что такое Работа.Выбран()
Гость
8 - 21.03.2012 - 09:49
оказывается по идентификатору колонки можно получить данные из справочника.
Гость
9 - 21.03.2012 - 09:54
(9) Да ну ???
А чего это Вы как в твиттере сами с собой разговариваете ?


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены