К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

как правильно использовать вычисленную ячейку ТЧ снова в вычислениях

Гость
0 - 22.02.2012 - 09:21
с помощью процедуры вычисляется значение ячейки

&НаКлиенте
Процедура РассчитатьФактичП() // Расчитывает фактический показатель в ТЧ

СтрокаТабличнойЧасти=Элементы.Энергоносители2012.Т екущиеДанные;
СтрокаТабличнойЧасти.ФактическийПоказатель=СтрокаТ абличнойЧасти.ФактическаяВыработкаЭлектроэнергии/СтрокаТабличнойЧасти.СуточнаяВыработкаЭлектроэнерг ии;
РассчитатьОтклонениеЭН()
КонецПроцедуры

Но уже если я с помощью другой процедуры вычисляю значение уже другой ячейки с участием вычисленной,то ерунда какая то получается... 9,99ь значение, хотя код правильный. Интуитивно я понимаю, что нужно присваивать переменной значение вычисленной ячейки а потом отнять другое значение... Прав ли я?
Но Даже если в коде я явно присваиваю статическое значение вычисляемой ячейки на основе первой вычисляемой, то значение все равно остается 9,99

Процедура РассчитатьОтклонениеЭН() // Расчитывает отклонениеЭН показатель в ТЧ

СтрокаТабличнойЧасти=Элементы.Энергоносители2012.Т екущиеДанные;
//СтрокаТабличнойЧасти.ОтклонениеЭлектроэнергии=Стро каТабличнойЧасти.ПлановыйСреднегодовойПоказательЭН-СтрокаТабличнойЧасти.ФактическаяВыработкаЭлектроэн ергии;

СтрокаТабличнойЧасти.ОтклонениеЭлектроэнергии=555;
КонецПроцедуры

&НаКлиенте
Процедура Энергоносители2012РасчетнаяСуточнаяПотребностьЭлек троэнергииПриИзменении(Элемент)
// Вставить содержимое обработчика.

РассчитатьФактичП();
РассчитатьОтклонениеЭНФакт();
РассчитатьОтклонениеЭН();
КонецПроцедуры



Гость
1 - 22.02.2012 - 09:26
Сначала посчитать, а потом присвоить что нужно по ячейкам
Гость
2 - 22.02.2012 - 09:27
То есть? через другие переменные?
Гость
3 - 22.02.2012 - 09:32
Ну да. Получи что надо из текущих данных, посчитай и засунь в нужные ячейки.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены