К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Как получить оборот?

Гость
0 - 02.08.2012 - 18:11
Подскажите плиз как получить дебетовый оборот по счету
в такой ситуации

Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьРазделительУчета(выбФирма);
Ит.ИспользоватьПланСчетов(ВыбранныйПланСчетов());
Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты);
Ит.ИспользоватьСубконто(ВидыСубконто.Заказы);
Ит.ВыполнитьЗапрос(НачМесяца(Дата1),Дата1,Счет);
Ит.ВыбратьСубконто();
Пока Ит.ПолучитьСубконто() = 1 Цикл
Клиент=Ит.Субконто(1);
начСальдо=Ит.СНК()
ДебОб= ???
ДебОб51Сч= ???
...



1 - 02.08.2012 - 18:15
развод? ,,2 или 3
Гость
2 - 02.08.2012 - 18:17
(1) не понял...
Гость
3 - 02.08.2012 - 18:18
(1) я привёл фрагмент, что-то не так?
4 - 02.08.2012 - 18:21
3-Apollo > а чуть-чуть почитать про ДО, КО, КорДО... и тип итогов?
Гость
5 - 02.08.2012 - 18:22
ДО, КорДО дает нулевой результат, а там не нулевой точно. Не понимаю в чём проблема
6 - 02.08.2012 - 18:28
типа Ит.ВыполнитьЗапрос(НачМесяца(Дата1),Дата1,Счет,,,3 );
и добавить
Ит.ВыбратьПериоды();
Ит.ВыбратьКорСчета();
Гость
7 - 02.08.2012 - 18:41
пробую)
Гость
8 - 02.08.2012 - 18:44
что-то не так((( всё равно нулевой результат
9 - 02.08.2012 - 18:47
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.Видыноменклат уры);
Ит.ВыполнитьЗапрос(ДатаНачала,ДатаКонца,Счет,,,3);
Ит.ВыбратьСубконто();
Пока Ит.ПолучитьСубконто() = 1 Цикл
ВидН=Ит.Субконто(1);
начСальдо=Ит.СНК();
ДебОб= Ит.ДО();
Ит.ВыбратьКорСчета(1);
Если Ит.ПолучитьКорСчет(,СчетПоКоду("10")) = 1 тогда
Сообщить("КорДО = " + Ит.КорДО());
Конецесли;
КонецЦикла;
10 - 02.08.2012 - 18:48
8-Apollo > что такое "Дата1"? что такое "Счет"? как выбираются кор счета? полный код в студию!
11 - 02.08.2012 - 18:53
(0) не забудь ролик выложить
Гость
12 - 02.08.2012 - 19:01
(10) дата1 - переменная формы.
Счет - это счет реализации (имеет два субконто "контрагенты" и "заказы"
Эта выбора строится верно! Не получается добиться поулчения дебетового оборота
Гость
13 - 02.08.2012 - 19:19
я опробовал текст из (9), выборку по корчетам не проходит совсем, будто бы она пустая.
Гость
14 - 02.08.2012 - 19:21
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьРазделительУчета(выбФирма);
Ит.ИспользоватьПланСчетов(ВыбранныйПланСчетов());
Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты);
Ит.ВыполнитьЗапрос(НачМесяца(Дата1),Дата1,Счет,,,3 );
Ит.ВыбратьСубконто();
Пока Ит.ПолучитьСубконто() = 1 Цикл
кли_=Ит.Субконто(1);
нач_=Ит.СНК();
кон_=Ит.СКК();
до_=0;
Ит.ВыбратьКорСчета(1);
Пока Ит.ПолучитьКорСчет()=1 Цикл
до_=до_+Ит.КорДО();
КонецЦикла;
КонецЦикла;
Гость
15 - 02.08.2012 - 19:23
(10) СПАСИБО - проблема была в датах! только что это заметил ((
16 - 02.08.2012 - 19:45
видно ушел побегать...
Гость
17 - 02.08.2012 - 20:21
уже вернулся))))
сейчас буду второй запрос добивать
Гость
18 - 02.08.2012 - 20:21
с первым разобрался, всё отлично
19 - 02.08.2012 - 20:29
вот здесь неверно:
нач_=Ит.СНК();
кон_=Ит.СКК();
.
запросто можно получить когда в ОСВ данные будут, а у тебя будет ноль...
20 - 02.08.2012 - 20:30
тьфу, не то.
предыдущий пост считать недействительным


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены