К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Как передать параметр в форму документа из формы списка документов???

Гость
0 - 13.06.2012 - 13:54
Мне нужно вводить документы с различными префиксами: МКДк, МКДп, и т.д. Для этого форму списка документов я добавил страницы ("закладки"). При вводе нового документа в зависимости от текущей "закладки" мне нужно УстановитьНовыйНомер() с префиксом этой "закладки".

Не знаю как передать из формы списка в форму документа значение переменной. Неужели только через глобальную переменную? Подскажите, пожалуйста как лучше?



Uho
1 - 13.06.2012 - 14:07
извратное решение устанавливать ПРЕФИКС номера документа в зависимости от способа интерактивного ввода

ЗЫ. ПараметрыФормы
Гость
2 - 13.06.2012 - 14:14
А почему, как по-другому?
Гость
3 - 13.06.2012 - 14:15
У меня куча договоров, с различными префиксами, нумерация которых должна быть у каждого своя.
Гость
4 - 13.06.2012 - 14:21
Платформа 6.0 - 7.х - 8.х?
Гость
5 - 13.06.2012 - 14:22
А с появлением нового префикса каждый раз новую закладку добавлять?
Uho
6 - 13.06.2012 - 14:22
3-nbab > не убедил
Гость
7 - 13.06.2012 - 14:29
у меня префиксов не более 6-ти...
Гость
8 - 13.06.2012 - 14:30
Да это мы уже проходили. Потом 126 появится )
Гость
9 - 13.06.2012 - 14:32
я вот так сделал:


Процедура ПриОткрытии()
Если ЭтоНовый() Тогда
Статус = Перечисления.СтатусДоговора.Действующий;
Форма = ЭтотОбъект.ПолучитьФорму("ФормаСписка", ЭтотОбъект.Ссылка);
Префикс = Форма.Отбор.ВидДоговора.Значение.Наименование;
УстановитьНовыйНомер(Префикс);
КонецЕсли;
КонецПроцедуры
Uho
10 - 13.06.2012 - 14:36
чукча-писатель
Гость
11 - 13.06.2012 - 14:50
Не спорю... посоветуй пожалуйста
Uho
12 - 13.06.2012 - 15:41
на вопросы ответь
Гость
13 - 14.06.2012 - 08:27
Процедура СписокПередНачаломДобавления(Элемент, Отказ, Копирование)
Отказ=Истина;
Форма = Документы.ХХХ.ПолучитьФорму("ФормаДокумента");
Форма.ВладелецФормы=ЭлементыФормы.Список;
Форма.Префикс=...
Форма.Открыть();
КонецПроцедуры
Гость
14 - 14.06.2012 - 08:28
Не дождавшись ответов, предполагаю, что вы уже обновились на 8.2. В этом случае, красивее всего использовать функционал динамических списков.
При наличии установленных отборов в дин списке по полям основной таблицы, в создаваемом новом объекте эти поля, по котором установлены отборы, будут автоматически заполнены установленными значениями отбора. Соответственно, при открытии формы нового документа можно проанализировать значение отбора и выставить в соответствии с ним префикс документа.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены