К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Изменяется задолженность по предприятию и работникам

0 - 22.12.2011 - 12:54
В течении всего года сальдо конечное в своде по зп не совпадает с сальдо на начало в следущем периоде. Точней разница между задолженностью предприятия и работниками не меняется, а вот сами задолженности разные. Где мы неправильно что делаем?


1 - 22.12.2011 - 12:56
П.С. ЗиК 7.7
Гость
2 - 22.12.2011 - 13:21
Все правильно. Так и задумано.
В бухии задолженность свернута. В ЗиКе - нет, в связи с необходимостью (согласно законодательству) отслеживать задолженности в выплатах по каждому месяцу.
Хотя не все это практикуют. Но отсюда - и "разбегание". На самом деле, просто нет "свертки".
Небольшая правка отчета - и ЩЯСТЯ :D
3 - 22.12.2011 - 13:36
Нет я понимаю почему она там развернута. Я не понимаю почему например:
Январь: задолженность за предприятием 10руб
за работниками 5руб
Февраль: за предприятием 8руб
за работниками 3руб.
Итоговое сальдо неизменяется, но долги то почему скачут :(? Что за небольшая правка? Может уже где лежит "правленный" отчет?
Гость
4 - 22.12.2011 - 13:45
Может уже где лежит "правленный" отчет?
Может, и лежит. Я сам правил. Там правок-то в двух местах...
5 - 22.12.2011 - 16:07
У меня даже лежит правленная конфига. Красота! "девятки" в сальдо теперь не вылезают, и сальдо конечное всегда сходится с начальным с точностью до развернутого.
6 - 23.12.2011 - 08:41
(5,6) А подглядеть дадите :)))?
7 - 23.12.2011 - 09:18
7-SergeyY >Дам, вот выпущу ЗИК 318 fix и дам подглядеть.
8 - 23.12.2011 - 11:45
(8) Спасибо. Где ждать/искать?
Гость
9 - 23.12.2011 - 18:40
7-SergeyY > Ну, вот как я изменил СводПоЗаработенойПлате:
1. Процедура Сформировать(ИмяОтчета="")
В тексе запроса 4 строки заремлены, 2 вставлены:
// |Функция ДолгРаботников = Сумма(Результат) когда (((Расчет=ВидРасчета.НачальноеСальдоЗадолженность) или(Расчет=ВидРасчета.НачальноеСальдоОкругления)ил и(Расчет=ВидРасчета.НачальноеСальдоПереплатаНДФЛ)) и (Результат < 0));
// |Функция ДолгПредприятия = Сумма(Результат) когда (((Расчет=ВидРасчета.НачальноеСальдоЗадолженность) или(Расчет=ВидРасчета.НачальноеСальдоОкругления)ил и(Расчет=ВидРасчета.НачальноеСальдоПереплатаНДФЛ)) и (Результат > 0));
|Функция ЗадолженностьПредприятия = Сумма(Результат) когда ((Расчет=ВидРасчета.НачальноеСальдоЗадолженность) и (Результат > 0));
// |Функция СальдоОкругленияРаботников = Сумма(Результат) когда ((Расчет=ВидРасчета.НачальноеСальдоОкругления) и (Результат < 0));
// |Функция СальдоОкругленияПредприятия = Сумма(Результат) когда ((Расчет=ВидРасчета.НачальноеСальдоОкругления) и (Результат > 0));
|Функция СальдоОкругления = Сумма(Результат) когда ((Расчет=ВидРасчета.НачальноеСальдоОкругления) и (Результат <> 0));

Далее (легко найти, где удаленные поля запроса использовались):

Если (ОтбиратьПоИФ = 0) и (ОтбиратьПоФКР = 0) и (ОтбиратьПоБД = 0) Тогда
//ДолгПредприятияНаНачалоМесяца = Запрос.ДолгПредприятия; //VZ. Будем формировать динамически
//ДолгРаботниковНаНачалоМесяца = -Запрос.ДолгРаботников; //VZ. Будем формировать динамически

ТаблицаЗапроса = СоздатьОбъект("ТаблицаЗначений");
Запрос.Выгрузить(ТаблицаЗапроса);
//ТаблицаЗапроса.Свернуть("ОсновнойЭлемент", "СуммаНачисления,СуммаУдержания,СуммаВыплаты,Сумма ВыплатыШтрафа,ВозвратВКассу,ДолгРаботников,ДолгПре дприятия,ЗадолженностьПредприятия");
ТаблицаЗапроса.Свернуть("ОсновнойЭлемент", "СуммаНачисления,СуммаУдержания,СуммаВыплаты,Сумма ВыплатыШтрафа,ВозвратВКассу,ЗадолженностьПредприят ия,СальдоОкругления,ПереплатаНДФЛПредприятия"); //VZ. Изменение.
ТаблицаЗапроса.ВыбратьСтроки();
Пока ТаблицаЗапроса.ПолучитьСтроку() = 1 Цикл
Если ПустоеЗначение(ТаблицаЗапроса.ОсновнойЭлемент) = 0 тогда
//VZ - изменил формирование долгов. Начало
Долг = ТаблицаЗапроса.ЗадолженностьПредприятия+ТаблицаЗап роса.СальдоОкругления+ТаблицаЗапроса.ПереплатаНДФЛ Предприятия;
Если Долг>0 Тогда
ДолгПредприятияНаНачалоМесяца = ДолгПредприятияНаНачалоМесяца + Долг;
Иначе
ДолгРаботниковНаНачалоМесяца = ДолгРаботниковНаНачалоМесяца - Долг;
КонецЕсли;
//VZ - изменил формирование долгов. Окончание

Оборот = ТаблицаЗапроса.СуммаНачисления - ТаблицаЗапроса.СуммаУдержания - ТаблицаЗапроса.СуммаВыплаты + ТаблицаЗапроса.ВозвратВКассу; //- ТаблицаЗапроса.СуммаВыплатыШтрафа
Если РасширенноеСальдо = 0 Тогда //VZ - заремленное - изменено
//ДолгПредприятияНаКонецМесяца = ДолгПредприятияНаКонецМесяца + Макс(ТаблицаЗапроса.ДолгПредприятия + ТаблицаЗапроса.ДолгРаботников + Оборот, 0);
//ДолгРаботниковНаКонецМесяца = ДолгРаботниковНаКонецМесяца + Мин(ТаблицаЗапроса.ДолгПредприятия + ТаблицаЗапроса.ДолгРаботников + Оборот, 0);
ДолгВКонцеМесяца = Долг + Оборот;
Если ДолгВКонцеМесяца>0 Тогда
ДолгПредприятияНаКонецМесяца = ДолгПредприятияНаКонецМесяца + ДолгВКонцеМесяца;
Иначе
ДолгРаботниковНаКонецМесяца = ДолгРаботниковНаКонецМесяца + ДолгВКонцеМесяца;
КонецЕсли;
Иначе
СальдоОкрСледПериода = глСальдоОкругления(ТаблицаЗапроса.ОсновнойЭлемент, ДатаАктуальности+1);
Если ТаблицаЗапроса.ЗадолженностьПредприятия > 0 Тогда
//ДолгПредприятияНаКонецМесяца = ДолгПредприятияНаКонецМесяца + Макс(ТаблицаЗапроса.ДолгПредприятия + ТаблицаЗапроса.ДолгРаботников + Оборот-СальдоОкрСледПериода, 0);
ДолгПредприятияНаКонецМесяца = ДолгПредприятияНаКонецМесяца + Макс(Долг + Оборот-СальдоОкрСледПериода, 0);
Иначе
//ДолгПредприятияНаКонецМесяца = ДолгПредприятияНаКонецМесяца + Макс(ТаблицаЗапроса.ДолгПредприятия + ТаблицаЗапроса.ДолгРаботников + Оборот, 0);
ДолгПредприятияНаКонецМесяца = ДолгПредприятияНаКонецМесяца + Макс(Долг + Оборот, 0);
КонецЕсли;
ДолгРаботниковНаКонецМесяца = ДолгРаботниковНаКонецМесяца + ?(СальдоОкрСледПериода < 0,СальдоОкрСледПериода,0);
КонецЕсли;
КонецЕсли;
КонецЦикла;
Иначе

...................
Ну, и в функции ПолучитьРасшифровкуСальдо() делаем в двух местах (разделенных Иначе) пару одинаковых замен:

//РасшифровкаСписка.Установить("СуммаСальдоОкруглени я", Запрос.СальдоОкругленияРаботников + Запрос.СальдоОкругленияПредприятия);
РасшифровкаСписка.Установить("СуммаСальдоОкруглени я", Запрос.СальдоОкругления); //VZ

Все, собственно :)
10 - 26.12.2011 - 07:13
(11) Спасибо. Попробую
11 - 26.12.2011 - 08:05
9-SergeyY >Да собственно вот ЗИК: Проблема накопленной задолженности из-за "неправильных" выплат (пост 11 Кондрат2)


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены