К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Галочка в многострочной части

Гость
0 - 20.03.2013 - 14:06
Я добавил на форме в многсотрочную часть колонку. Картинку быврал. Указал "Показывать пиктограммы". Указал Формулу - Пометка().

саму функцию прописал:

Функция Пометка()

Если Пометка=1 Тогда
Возврат "0";
Иначе
Возврат "1";
КонецЕсли;

КонецФункции

Итог: колонка отображается, квадратик для галочки тоже, но поставить галочку не получается. Что не так?



Гость
1 - 20.03.2013 - 14:15
Надо перехватить жамканье по этой колонке. И менять значение с "0" на "1", и с "1" на "0".
Гость
2 - 20.03.2013 - 14:28
Цитата:
Сообщение от VZ Посмотреть сообщение
Надо перехватить жамканье по этой колонке. И менять значение с "0" на "1", и с "1" на "0".
Перехватить - ПриНачалеРедактирования ?
Гость
3 - 20.03.2013 - 14:37
2-mykuban > Нет, надо выбирать модули формы, а не объекта.
ПриНачалеВыбораЗначения().
Гость
4 - 20.03.2013 - 14:52
Функция Пометка()

Вернуть=0;
Если Пометка=1 Тогда
Вернуть=0;
Иначе
Вернуть=1;
КонецЕсли;

Возврат Вернуть;
КонецФункции

Процедура ПриНачалеВыбораЗначения()

Если Пометка=1 Тогда
Пометка=0;
Иначе
Пометка=1;
КонецЕсли;

КонецПроцедуры

вот так. тоже не ставятся галочки.
Гость
5 - 20.03.2013 - 15:07
Ну, зачиЦЦа так (посмотрел работающую):
Процедура ОбрабТЗ()
Если ТЗ.ТекущаяКолонка()="Удалять" Тогда
Если ТЗ.Удалять="Х" Тогда ТЗ.Удалять=""; Иначе ТЗ.Удалять="Х"; КонецЕсли;
КонецЕсли;
КонецПроцедуры

Функция ОбрабТЗ() наложена на всю ТЧ (в свойствах), колонка "Удалять" - та, где оператор делает поментку, но вместо "галочки" применил "Х" - лень было цеплять картинку.
Гость
6 - 20.03.2013 - 15:15
У меня не таблица значений. а многострочная часть. в ней некуда в свойствах прицепить процедуру.

как сделать для таблицы значений галочки я знаю, уже делал. а вот мне стало интересно попробовать для многострочной части. не получается пока.
Гость
7 - 20.03.2013 - 15:21
на вот, ознакамливайся
http://rusfolder.com/35567809
Гость
8 - 20.03.2013 - 15:40
Ура. Заработала. Хотя я смутно понимаю как.
Гость
9 - 20.03.2013 - 16:42
Код:
Функция Пометка()
	Вернуть=1-Пометка;
	Возврат Вернуть;
КонецФункции
И откуда только такое берётся..


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены