К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

ФИча - ошибка печати из формулы атрибута на форме.

0 - 21.02.2018 - 11:35
давно не сталкивался с фичами 1С 7.7. Кто то боролся с такой "фичей" : на форме внешней обработки есть поле ввода ( строка ) . туда что то вносят , и у этого поля ввода есть "формула" - вызывается процедура , которая вносит данные из этого поля в список значений на этой же форме. но фича в том, что если в этой процедуре вызывать вызов на печать , то выходит ошибка. не находит секцию, или если исходная таблица имеет другое имя ( не "Таблица" ), то не находит ее.



Отредактировано specx; 21.02.2018 в 11:36. Причина: 1
1 - 21.02.2018 - 12:00
Перем Таб;
2 - 21.02.2018 - 12:04
Цитата:
Сообщение от user1C Посмотреть сообщение
Перем Таб;
не помогает :(
3 - 21.02.2018 - 12:08
точно не помню, но по моему надо в дополнение к (1) Таб определить ПриОткрытии()
4 - 21.02.2018 - 12:17
(2)
в глобальном контексте модуля?
5 - 21.02.2018 - 12:58
Цитата:
Сообщение от user1C Посмотреть сообщение
(2) в глобальном контексте модуля?
да, в глоб тексте модуля сверху всех процедур.

Цитата:
Сообщение от USSR Посмотреть сообщение
точно не помню, но по моему надо в дополнение к (1) Таб определить ПриОткрытии()
добавил также не помогло...

кстати, делаю примитивную ручную агрегацию коробов егаис :)
6 - 21.02.2018 - 13:02
Цитата:
Сообщение от СпецХ Посмотреть сообщение
добавил также не помогло...
А если инициализировать не в ПриОткрытии(), а тоже в тексте, ниже всех процедур? Смутно помнится, что вроде есть какие-то отличия.
7 - 21.02.2018 - 13:09
Цитата:
Сообщение от Ткачик Посмотреть сообщение
Цитата: Сообщение от СпецХ добавил также не помогло... А если инициализировать не в ПриОткрытии(), а тоже в тексте, ниже всех процедур? Смутно помнится, что вроде есть какие-то отличия.
попробовал - не помогло. также смутно помню что от атрибута еще что-то не работает. а очень мне в данном случае хочется чтобы именно от атрибута сработало. то есть - идея такая : набираю/сканирую в список количество акцизок pdf417,количество которое задано предварительно. затем генерю этикетку и выдаю ее сразу на принтер этикеток. обнуляю список. и приступаем к следующему коробу.

Отредактировано specx; 21.02.2018 в 13:14. Причина: добавка
8 - 21.02.2018 - 15:10
вот держи

если нужно сразу на печать без показа окна, то можно без фокусов в ПриЗакрытии, просто из формулы напрямую нельзя открывать окна


Перем таб;
Перем можноЗакрыть;

Процедура ПриИзменении()
таб.ВывестиСекцию("111");
можноЗакрыть = 0;
Форма.Закрыть();
КонецПроцедуры

Процедура ПриОткрытии()
таб = СоздатьОбъект("Таблица");
таб.ИсходнаяТаблица("Таблица111");
КонецПроцедуры

Процедура ПриЗакрытии()
Если можноЗакрыть = 0 Тогда
можноЗакрыть = 1;
таб.Показать();
Активизировать("ПолеВвода",0);
СтатусВозврата(0);
Возврат;
КонецЕсли;
КонецПроцедуры

можноЗакрыть = 1;
9 - 21.02.2018 - 16:39
Цитата:
Сообщение от runuts Посмотреть сообщение
вот держи если нужно сразу на печать без показа окна, то можно без фокусов в
специально создал тестовую обработку, попробовал - работает !

спасибо !

я правда начал уже делать в своей через файлы...


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены