К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Есть ли возможность из 1С отправлть напрямую команды на COM порт ?

med
0 - 22.05.2012 - 06:22
Я искал по инету и форуму, но везде описан обратный процесс - как считать напрямую данные с COM порта.
А здесь - наоборот отправка данных
Если взять глобальнее - это один из вариантов решения проблемы отправки SMS из 1С.
(Предполагается на COM порт поставить GSM - модем и через него набором команд отправлять SMS)
Или может подскажете, каким ещё образом можно SMS через GSM - модем отправлять ?



Гость
1 - 22.05.2012 - 07:22
а ДЛЯ ЧЕГО 1с то ??
Гость
2 - 22.05.2012 - 07:42
А зачем СОМ- порт? Используй интернет- сервисы, их много разных.
Поиск "смс интернет бесплатно"
med
3 - 22.05.2012 - 07:50
Цитата:
Сообщение от briz Посмотреть сообщение
briz 1 - Сегодня - 08:22 а ДЛЯ ЧЕГО 1с то ??
Нуууу много для чего, скажем отсылать клиенту автоматом SMS, что его товар пришел, или что отсрочка платежа заканчивается..
Цитата:
Сообщение от Зомби Посмотреть сообщение
Зомби 2 - Сегодня - 08:42 А зачем СОМ- порт? Используй интернет- сервисы, их много разных. Поиск "смс интернет бесплатно"
Просто хотим сделать самодостаточную систему не зависящую от интернета и провайдеров.
Гость
4 - 22.05.2012 - 08:01
(3)А мыло уже не рулит? Сдается мне батенька, Вы спам хотите запустить с левых мобильных номеров.
med
5 - 22.05.2012 - 08:20
Цитата:
Сообщение от Зомби Посмотреть сообщение
Зомби 4 - Сегодня - 09:01 (3)А мыло уже не рулит? Сдается мне батенька, Вы спам хотите запустить с левых мобильных номеров.
Мыло уже сделали - тут то как раз проблем не возникло - описаний до чертиков, теперь хотим, что бы дублировалось и на сотовый.
6 - 22.05.2012 - 08:21
Гугль рулит: http://www.cyberforum.ru/1c/thread314966.html

Не мое, не щупал, хвалите и ругайте сами.
med
7 - 22.05.2012 - 08:21
4-Зомби > пока все попадается типа
http://www.headwind.ru/1c.php
med
8 - 22.05.2012 - 08:25
6-Ткачик > Спасибо, это свободный доступ к файлу
http://infostart.ru/public/85792/
правда прикол, что там написано - триальная версия до 01/07/2011 :-)
Гость
9 - 24.05.2012 - 13:01
вполне будет работать
ФСО=СоздатьОбъект("Scripting.FileSystemObject");
Порт=ФСО.OpenTextFile("\\.\com1",8);
Порт.WriteLine("ATDT234556");
Порт.Close();

и даже

КомандаСистемы("cmd /c echo ATDT234556 >> \\.\com1");
med
10 - 25.05.2012 - 09:02
Вроде бы нашел два варианта
один через внешнюю компоненту :
RS=Новый COMОБъект("MSCOMMLib.MSComm");
RS.Settings = "115200,n,8,1";
RS.CommPort=5;
RS.Handshaking = 1;
RS.RThreshold = 1;
RS.SThreshold = 1;
RS.InputLen = 0;
RS.RTSEnable = 1;
RS.InputMode = 0 ;

Если RS.PortOpen тогда
RS.PortOpen=false;
КонецЕсли;
RS.PortOpen=True;
Сообщить("Порт ОТкрыт");

RS.Output="ATIMEI"+Символ(13);

сч=0;
Буфер="";
Пока ((Найти(СокрЛП(Буфер),"OK")=0) И (Найти(СокрЛП(Буфер),"ERROR")=0)) ИЛИ (сч=50000) Цикл
Буфер=Буфер+СокрЛП(RS.Input);
сч=сч+1;
КонецЦикла;
Сообщить(сч);
Сообщить(Буфер);

Всё прекрасно работает, но.. минус в использовании внешней компоненты.
Еще работает способ через запись/считывание:

модемЧ = Новый ЗаписьТекста("\\.\Com5",КодировкаТекста.ANSI);
Строк="ATIMEI"+Символ(13);
модемЧ.ЗаписатьСтроку(Строк);
Сообщить("Отправлена строка - "+ТекущаяДата());
модемЧ.Закрыть();
МодемЧ= Новый ЧтениеТекста();
МодемЧ.Открыть("\\.\Com5",КодировкаТекста.ANSI);
сч=0;
Буфер="";
Сообщить("Начало ожидания ответа - "+ТекущаяДата());
Пока ((Найти(СокрЛП(Буфер),"OK")=0) И (Найти(СокрЛП(Буфер),"ERROR")=0)) Цикл
Состояние(сч);
Буфер=Буфер+СокрЛП(МодемЧ.ПрочитатьСтроку());
Сообщить("Время цикла - "+ТекущаяДата());
сч=сч+1;
КонецЦикла;
Сообщить(сч);
Сообщить(Буфер);
Сообщить("Получен Ответ - "+ТекущаяДата());
Здесь всё хорошо ничего внешнего не используется, но обнаружились странные задержки по времени:
Отправлена строка - 25.05.2012 11:37:36
Начало ожидания ответа - 25.05.2012 11:37:36
Время цикла - 25.05.2012 11:38:42
Время цикла - 25.05.2012 11:38:42
Время цикла - 25.05.2012 11:38:42
Время цикла - 25.05.2012 11:38:42
Время цикла - 25.05.2012 11:38:42
Время цикла - 25.05.2012 11:38:42
Время цикла - 25.05.2012 11:38:42
Время цикла - 25.05.2012 11:38:42
Время цикла - 25.05.2012 11:38:42
Время цикла - 25.05.2012 11:38:42
Время цикла - 25.05.2012 11:38:42
Время цикла - 25.05.2012 11:38:42
Время цикла - 25.05.2012 11:38:42
Время цикла - 25.05.2012 11:39:15

ATIMEIManufacturer: TCT Mobile International LimitedModel: HSPA Data CardRevision: WX111000XXIMEI: 355249042491906+GCAP: +CGSM,+FCLASS,+DSManufacturer: TCT Mobile International LimitedModel: HSPA Data CardRevision: WX111000XXIMEI: 355249042491906+GCAP: +CGSM,+FCLASS,+DSOK
Получен Ответ - 25.05.2012 11:39:15
Т.е. ожидание ответа почти две минуты,
Это неприемлемо
Из-за чего может быть такой долгий срок ответа ?


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены