К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Дублирование чеков

0 - 10.06.2013 - 08:01
Всем привет.
Конфигурация ТиС для 7.7. БД распределённая и конфигурация точно такая же как на всех торговых точках. В одном из магазинов на той неделе поставили фискальный регистратор и начались проблемы.
Умудряются пробивать чеки по 2 раза. Я так понимаю либо не всегда заполняется реквизит приходного кассового ордера - номер чека.
Какие мысли по этому поводу? Обработка печати чеков такая же как и в других магазинах.



1 - 11.06.2013 - 11:14
Ну вот как-то так. Только причем тут приходник??? И еще: у Вас чек пробивается в модуле проведения документа???
Если Проведен()=1 Тогда
//Сообщить("Печать Чека на ККМ");
// пробьем чек на ККМ
Если Касса.РежимККМ = Перечисление.РежимыККМ.ФР Тогда
Если глФРВкл = 1 Тогда
Если ЧекПробитККМ = 0 Тогда
Если ПробитьЧекНаККМ() = 0 Тогда

// по каким-то причинам Чек не пробит
Сообщить("Чек ККМ не пробит!");
Возврат;

КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены