К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

DialMail.dll и FTP 1С7.7

Гость
0 - 28.11.2014 - 14:44
День добрый. Помогите разобраться с проблемой.

Исходные данные:
Платформа: 1С7.7
ОС: Windows 7 (у клиентов не помню, но все равно не работает)
компонента: DialMail.dll версия 2.7.6.16
и FTP

Проблема:
метод FTP.КоличествоФайлов() - возвращает 0, хотя файлы точно есть
так же FTP.ПолучитьИмяФайла(1) - возвращает ""
в ранней версии все работает, но на этой длл завязана не только работа с FTP и вообще как то не кошерно ставить старую версию.

Вопрос: как решить, может кто знает?

Листинг:
Если ЗагрузитьВнешнююКомпоненту(КаталогИБ() + "DialMail.dll")=0 Тогда
Сообщить("Не удалось обнаружить компоненту DialMail.dll!");
Возврат 0;
КонецЕсли;
FTP = СоздатьОбъект("AddIn.FTP");
FTP.ИмяЛогФайла = КаталогИБ()+"\_ftp.log";
FTP.ВестиЛогФайл = 1;
FTP.ВестиТехническийЛогФайл = 1;
FTP.NewRFC = 0;
FTP.Подключиться(ИмяСервераФТП,ПортСервераФТП,ИмяП ользователяФТП,ПарольПользователяФТП)

Если FTP.Лист()=0 Тогда
Сообщить("Не удалось подключиться к папке");
Возврат 0;
КонецЕсли;
Для инд = 1 по FTP.КоличествоФайлов() Цикл
Если FTP.ЭтоКаталог(инд) = 1 Тогда
Продолжить;
КонецЕсли;
ИмяФайла = FTP.ПолучитьИмяФайла(инд);
Сообщить(ИмяФайла);
КонецЦикла;



1 - 28.11.2014 - 16:55
Попробуй
Если FTP.Лист("/",)=1 тогда
Гость
2 - 28.11.2014 - 20:37
C фтп работает проводник из 1с безо всяких ВК
Гость
3 - 28.11.2014 - 22:06
Sasha-нет
smaharbA-можно подробнее, хотя бы маленький пример?
Гость
4 - 28.11.2014 - 22:10
smaharbA напоминаю, что 1с7.7
Гость
5 - 28.11.2014 - 22:10
СоздатьОбъект("shell.application")

и далее с фтп папками как с локальными, лгин и пароль по правилам УРЛ
Один момент - нужно самому отслеживать окончание загрузки/выгрузки файла/файлов - процесс асинхронен
Гость
6 - 28.11.2014 - 22:11
спасибо.
Гость
7 - 28.11.2014 - 22:14
но если кто -то даст ответ и на первоначальный вопрос. то же буду благодарна :-)
8 - 28.11.2014 - 22:34
(3,7)А нет ли ничего интересного в файле КаталогИБ()+"\_ftp.log", что могло бы прояснить ситуацию? :-)
Гость
9 - 30.11.2014 - 11:50
Я лично не смог побороть данный глюк и поставил другую версию, в которой все работает..
Гость
10 - 30.11.2014 - 22:46
mikiton-ага, вчера "осенило" положу рядом 2 длл разных версий -переменную просто вторую:)
Гость
11 - 06.04.2015 - 00:31
Как вариант 1С Планировщик
infostart.ru/public/15995/


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены