К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Бух 8 Реализация товаров и услуг

Гость
0 - 13.08.2012 - 11:12
При реализации товара не правильно списывает себестоимость со счета 43.01
Кручу оборотносальдовую по счету 43.01 по данной номенклатуре
Остаток Сумма 162667,93 количество 48,43
В документе реализация количество товара = 30,856
Тоесть по идее сумма списания должна быть 162667,93/48,43*30,856= 103639,93
при проведении документа ставит сумму списания другую (103589,35)
поковырял отладчик выяснилось что откуда-то он берет другую сумму в часности 163411,06/48,675*30,856
В остаткакх ничего другого нет. Откуда кроме остатков по счету 1с берет цифры? может с какого регистра а то я никак не могу сообразить (запрось большой там путаюсь)



1 - 13.08.2012 - 11:29
Остатки берутся только их бухрегистра. Партионный учет?
Гость
2 - 13.08.2012 - 11:30
Учет не партионный, склад один. Немогу понять что за бред.
Гость
3 - 13.08.2012 - 11:33
Выбирает вот этим запросом:
Если СчетаУчетаН.Количество() > 0 Тогда

Текст = Текст + "
|ВЫБРАТЬ
| Остатки.Счет КАК СчетУчета,
| Остатки.Подразделение КАК Подразделение,
| Остатки.Субконто1 КАК Номенклатура,
| &ПустаяДата КАК ДокументОприходованияДата,
| &ПустаяПартия КАК ДокументОприходования,
| &ПустаяДата КАК ДокументОтгрузкиДата,
| &ПустаяОтгрузка КАК ДокументОтгрузки,
| " + ?(СчетаУчетаН_Склад.Количество() > 0, "ОстаткиПоСкладам.Субконто2", "&ПустойСклад")+ " КАК Склад,
| Остатки.Организация КАК Организация,
| СУММА(ВЫБОР КОГДА " + ?(СчетаУчетаН_Склад.Количество() > 0, "ОстаткиПоСкладам", "Остатки")+ ".КоличествоОстатокДт ЕСТЬ NULL ТОГДА 0 ИНАЧЕ " + ?(СчетаУчетаН_Склад.Количество() > 0, "ОстаткиПоСкладам", "Остатки")+ ".КоличествоОстатокДт КОНЕЦ) КАК КоличествоПоСкладу,
| СУММА(ВЫБОР КОГДА Остатки.КоличествоОстатокДт ЕСТЬ NULL ТОГДА 0 ИНАЧЕ Остатки.КоличествоОстатокДт КОНЕЦ) КАК Количество,
| СУММА(ВЫБОР КОГДА Остатки.СуммаОстатокДт ЕСТЬ NULL ТОГДА 0 ИНАЧЕ Остатки.СуммаОстатокДт КОНЕЦ) КАК Стоимость,
| СУММА(ВЫБОР КОГДА Остатки.СуммаНУОстатокДт ЕСТЬ NULL ТОГДА 0 ИНАЧЕ Остатки.СуммаНУОстатокДт КОНЕЦ) КАК СтоимостьНУ,
| СУММА(ВЫБОР КОГДА Остатки.СуммаПРОстатокДт ЕСТЬ NULL ТОГДА 0 ИНАЧЕ Остатки.СуммаПРОстатокДт КОНЕЦ) КАК СтоимостьПР,
| СУММА(ВЫБОР КОГДА Остатки.СуммаВРОстатокДт ЕСТЬ NULL ТОГДА 0 ИНАЧЕ Остатки.СуммаВРОстатокДт КОНЕЦ) КАК СтоимостьВР
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.Остатки(&МоментКон , Счет В (&СчетаУчетаН), &ВидыСубконтоН," + ?(ЗначениеЗаполнено(ФильтрПодразделения), "(Подразделение В (&ФильтрПодразделения) ИЛИ Подразделение ЕСТЬ NULL) И ", "") + "Субконто1 В (&Номенклатура) И Организация В (&Организации)) КАК Остатки
| " + ?(СчетаУчетаН_Склад.Количество() > 0, "ЛЕВОЕ СОЕДИНЕНИЕ РегистрБухгалтерии.Хозрасчетный.Остатки(&МоментКон , Счет В (&СчетаУчетаН_Склад), &ВидыСубконтоНС, " + ?(ЗначениеЗаполнено(ФильтрПодразделения), "(Подразделение В (&ФильтрПодразделения) ИЛИ Подразделение ЕСТЬ NULL) И ", "") + "Субконто1 В (&Номенклатура) И Субконто2 В (&Склады) И Организация В (&Организации)) КАК ОстаткиПоСкладам
| ПО Остатки.Счет = ОстаткиПоСкладам.Счет
| И Остатки.Субконто1 = ОстаткиПоСкладам.Субконто1", "")+ "
|
|СГРУППИРОВАТЬ ПО
| Остатки.Счет,
| Остатки.Подразделение,
| Остатки.Субконто1, " + ?(СчетаУчетаН_Склад.Количество() > 0, "
| ОстаткиПоСкладам.Субконто2,", "")+ "
| Остатки.Организация";

КонецЕсли;
Гость
4 - 13.08.2012 - 11:37
Ошибся выбирает вот этим запросом:
Если СчетаУчетаНС.Количество() > 0 Тогда

Если Текст <> "" Тогда
Текст = Текст + "
|
| ОБЪЕДИНИТЬ ВСЕ
|
|";
КонецЕсли;

Текст = Текст + "ВЫБРАТЬ
| Остатки.Счет КАК СчетУчета,
| Остатки.Подразделение КАК Подразделение,
| Остатки.Субконто1 КАК Номенклатура,
| &ПустаяДата КАК ДокументОприходованияДата,
| &ПустаяПартия КАК ДокументОприходования,
| &ПустаяДата КАК ДокументОтгрузкиДата,
| &ПустаяОтгрузка КАК ДокументОтгрузки,
| Остатки.Субконто2 КАК Склад,
| Остатки.Организация КАК Организация,
| СУММА(ВЫБОР КОГДА Остатки.КоличествоОстатокДт ЕСТЬ NULL ТОГДА 0 ИНАЧЕ Остатки.КоличествоОстатокДт КОНЕЦ) КАК КоличествоПоСкладу,
| СУММА(ВЫБОР КОГДА Остатки.КоличествоОстатокДт ЕСТЬ NULL ТОГДА 0 ИНАЧЕ Остатки.КоличествоОстатокДт КОНЕЦ) КАК Количество,
| СУММА(ВЫБОР КОГДА Остатки.СуммаОстатокДт ЕСТЬ NULL ТОГДА 0 ИНАЧЕ Остатки.СуммаОстатокДт КОНЕЦ) КАК Стоимость,
| СУММА(ВЫБОР КОГДА Остатки.СуммаНУОстатокДт ЕСТЬ NULL ТОГДА 0 ИНАЧЕ Остатки.СуммаНУОстатокДт КОНЕЦ) КАК СтоимостьНУ,
| СУММА(ВЫБОР КОГДА Остатки.СуммаПРОстатокДт ЕСТЬ NULL ТОГДА 0 ИНАЧЕ Остатки.СуммаПРОстатокДт КОНЕЦ) КАК СтоимостьПР,
| СУММА(ВЫБОР КОГДА Остатки.СуммаВРОстатокДт ЕСТЬ NULL ТОГДА 0 ИНАЧЕ Остатки.СуммаВРОстатокДт КОНЕЦ) КАК СтоимостьВР
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.Остатки(&МоментКон , Счет В (&СчетаУчетаНС), &ВидыСубконтоНС, " + ?(ЗначениеЗаполнено(ФильтрПодразделения), "(Подразделение В (&ФильтрПодразделения) ИЛИ Подразделение ЕСТЬ NULL) И ", "") + "Субконто1 В (&Номенклатура) И Субконто2 В (&Склады) И Организация В (&Организации)) КАК Остатки
|
|СГРУППИРОВАТЬ ПО
| Остатки.Счет,
| Остатки.Подразделение,
| Остатки.Субконто1,
| Остатки.Субконто2,
| Остатки.Организация";

КонецЕсли;

Тоеть по номенклатуре и складу
Гость
5 - 13.08.2012 - 12:11
Вообщем в запросе походу все правильно далее когда в процедуре ПОдобратьПартии
СтрокаНоменклатуры = ДеревоОстатковПартий.Строки.Найти(СтрокаДокумента. Номенклатура, "Номенклатура");


СтрокаНоменклатуры.Количество = 48,43
СтрокаНоменклатуры.Стоимость= 162667,93

Но затем идет обход по строкам дерева а там

СтрокаНоменклатуры.Строки[0].Количество =48,675
СтрокаНоменклатуры.Строки[1].Количество =-0,245
СтрокаНоменклатуры.Строки[0].Стоимость = 163411,06СтрокаНоменклатуры.Строки[1].Стоимость =-743,13

немогу понять почему так бьет
Гость
6 - 13.08.2012 - 12:31
сделай тии, походу платформу не обновлял
7 - 13.08.2012 - 12:39
на какой момент времени запрос выбирает данные?
8 - 13.08.2012 - 17:32
(6) +1
по ходу, перед нами в лице автора - видимо последний из 100500 обновляльщиков БП, наступивших на эти грабли с обновлением платформы.
Форум надо почитывать почаще.
Если сначала обновил конфигу, потом обновил платформу - тады ищи бэкап.
И да, кстати - ТиИ не всегда помогает при этих граблях.
9 - 13.08.2012 - 19:17
(5) а посмотреть откуда лезет отрицательное колво?


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены