К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

БП 8.3.7.1845. После обновления исчезла доступность заполнения адреса

0 - 19.04.2016 - 19:55
Юридического и Фактического. Бухша сегодня звонит - в шоке. Причем у некоторых остался заполненный адрес, а у некоторых - слетел и адрес и доступность. Подозреваю, что не по КЛАДРу (FIAS) был заполнен, а от руки. Но исправить-то как?


1 - 19.04.2016 - 19:56

вот как-то так.
Гость
2 - 19.04.2016 - 21:19
БП3, текущая редакция 3.0.43 рекомендована для использования на платформе 8.3.6.2449 (не самая последняя в линейке 8.3.6!).
Ну, и зачем лезть на платформу, на которой конфа не обкатана? И которую сами разработчики БП3 предполагают использовать где-то к осени?

Острых ощущений хочется?

Одновременно можно держать целую связку платформ, а конкретную конфу можно привязать к конкретной платформе. Задай в запускалке (или в опциях) не 8.3, а 8.3.6.2449 - подхватится именно эта платформа.
А 8.3.7 оставь ЗУП.
3 - 20.04.2016 - 00:09
2-VZ > блин, вместо релиза БП написал релиз платформы.
Бухгалтерия предприятия 3.0.43.174 - вот оно.
Так что, дело в платформе?
4 - 20.04.2016 - 00:58
Понижение релиза платформы не помогло
5 - 20.04.2016 - 10:11
(0) в справочнике "виды контактной информации" всё нормально?
6 - 20.04.2016 - 10:50
5-roma n > не совсем


Да, после обновления на последний релиз, накатывал обнову для перехода с базовой на проф. Все прошло штатно. И до обновления все работало....
7 - 20.04.2016 - 10:55
В списке видов контактной информации как они выглядят?
Интересно не расплодились ли в нём дубли, являются ли элементы предопределёнными.
8 - 20.04.2016 - 17:31
7-roma n >
Гость
9 - 20.04.2016 - 20:16
Чё то не нахожу такой зарегистрированной ошибки в 43. В списке неисправленных - тоже.
Смотрел сегодняшнее обновление 3.0.43.194

Силком надо исправлять, похоже.
Перед этим проверить ИБ на переполнение таблиц (4Гб)
10 - 20.04.2016 - 21:42
Цитата:
Сообщение от VZ Посмотреть сообщение
Перед этим проверить ИБ на переполнение таблиц (4Гб)
Дык вот же. Прежде, чем ломать, хотелось узнать... Вся база 1,8Г.
11 - 20.04.2016 - 22:03
Да, 194 накатил - ничего не изменилось.
12 - 21.04.2016 - 05:28
(11) Для начала неплохо бы почистить кэша 1С-ные, сделать бэкап базы, потом ТиИИБ с реструктуризацией.
И вот только уже потом проверить соответствие видов контактной информации типам. Если ранее выполнялся переход с БП2.0 на БП3.0, то с КИ в таких случаях бывает полная >I<.
Для установки соответствия видов КИ (это справочник) типам КИ (это перечисление) делаем простенькую внешнюю обработку.
На форме два поля ввода:
1. ЭлементНСИ - СправочникСсылка.ВидыКонтактнойИнформации
2. Тип - ПеречислениеСсылка.ТипыКонтактнойИнформации
и одна кнопка "Установить Тип", на которой висит обработчик Установить(Команда).
Ниже весь код управляемой формы:

&НаКлиенте
Процедура Установить(Команда)
УстановитьНаСервере();
КонецПроцедуры

&НаСервере
Процедура УстановитьНаСервере()
ТекОб = Объект.ЭлементНСИ.ПолучитьОбъект();
ТекОб.ОбменДанными.Загрузка = Истина;
ТекОб.Тип = Объект.Тип;
ТекОб.Записать();
КонецПроцедуры
13 - 21.04.2016 - 09:17
12-oops! >
9-VZ >
Может, я чего-то не понимаю, но ЮА и ФАдрес - ПолеНадписи! В вводить где????
14 - 26.04.2016 - 10:09
В общем, если кто-нить наткнется на те же грабли - поможет
---------------------------------------------------------------------

&НаСервере
Процедура Команда1НаСервере()

ОбъектВКИ = Справочники.ВидыКонтактнойИнформации.ЮрАдресКонтра гента.ПолучитьОбъект();
ОбъектВКИ.МожноИзменятьСпособРедактирования=Истина ;
ОбъектВКИ.РедактированиеТолькоВДиалоге=Истина;
ОбъектВКИ.Записать();

ОбъектВКИ = Справочники.ВидыКонтактнойИнформации.ПочтовыйАдрес Контрагента.ПолучитьОбъект();
ОбъектВКИ.МожноИзменятьСпособРедактирования=Истина ;
ОбъектВКИ.РедактированиеТолькоВДиалоге=Истина;
ОбъектВКИ.Записать();

ОбъектВКИ = Справочники.ВидыКонтактнойИнформации.ФактАдресКонт рагента.ПолучитьОбъект();
ОбъектВКИ.МожноИзменятьСпособРедактирования=Истина ;
ОбъектВКИ.РедактированиеТолькоВДиалоге=Истина;
ОбъектВКИ.Записать();

КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
Команда1НаСервере();
КонецПроцедуры

--------------------------------------------------------------------------------------


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены