К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

7.7 бух не сохраняет дату отч в новом РСВ

0 - 06.07.2015 - 13:28
7.7 бух не сохраняет дату отч в новом РСВ, никто не помнит как сделать, чтобы было нормально? Была такая же фигня вроде то ли с ФСС, то ли с имуществом в прошлом квартале. Я раньше не знал, а теперь забыл :(


1 - 06.07.2015 - 13:46
Цитата:
Сообщение от Фдуч Посмотреть сообщение
Я раньше не знал, а теперь забыл
А мне интересно: как можно забыть то что не знаешь?
Гость
2 - 06.07.2015 - 14:12
Фото ТС в юности
3 - 06.07.2015 - 15:07
(0) Кури здесь (титульный лист, начиная со строки 9093)
Дата1 = НачГода(Дата2); //Ошибка здесь, Дата1=01.01.15
//Проверка на соответствие периоду, с которого действует форма
Если (Дата1 < Дата(ВерсияФормы)) или (Дата2 < Дата(ВерсияФормы)) или (ДатаВысылкиОтчета < Дата(ВерсияФормы)) Тогда
//Если какая-то дата старее начала действия, то меняем все даты
ДатаВысылкиОтчета = Дата(ВерсияФормы);
Дата1 = Дата(ВерсияФормы);
Дата2 = КонКвартала(Дата1); //Форма квартальная
КонецЕсли;
Гость
4 - 06.07.2015 - 15:29
еще один подсказчик
5 - 06.07.2015 - 15:37
(4) угу
эти "удоды" за основу взяли форму РСВ из 1-го квартала,
и Дата1 у них во всех местах определяется как
Дата1 = НачГода(Дата2);
что неверно
6 - 06.07.2015 - 16:09
Правильной ответ: какие могут быть претензии к неутвержденной форме, см. Новая форма РСВ-1
Гость
7 - 07.07.2015 - 22:19
не проще ли вручную дату подписания исправить ?
И потом ЧекПФР от 29.06.15 прекрасно воспринимает.
8 - 09.07.2015 - 09:31
7-Плюшкин > - зачем поощрять создание ошибок?
во всех формах RSV*.ert
в части модулей:
//Проверка на соответствие периоду, с которого действует форма
Если (Дата(Дата1) < Дата(ВерсияФормы)) или (Дата(Дата2) < Дата(ВерсияФормы)) или (ДатаВысылкиОтчета < Дата(ВерсияФормы)) Тогда
//Если какая-то дата старее начала действия, то меняем все даты
ДатаВысылкиОтчета = Дата(ВерсияФормы);
Дата1 = Дата(ВерсияФормы);
Дата2 = КонКвартала(Дата1); //Форма квартальная
КонецЕсли;

Заменить на
Если
//(Дата(Дата1) < Дата(ВерсияФормы)) или
(Дата(Дата2) < Дата(ВерсияФормы)) или (ДатаВысылкиОтчета < Дата(ВерсияФормы)) Тогда
//Если какая-то дата старее начала действия, то меняем все даты
//ДатаВысылкиОтчета = Дата(ВерсияФормы);
Дата1 = Дата(ВерсияФормы);
Дата2 = КонКвартала(Дата1); //Форма квартальная
ДатаВысылкиОтчета = Дата(Дата2+1);
КонецЕсли;

- тогда, при повторном открытии, формы открываются по уже прописанной дате высылки в титульном листе.
9 - 09.07.2015 - 09:47
8-perpetum >+ можно качнуть здесь:
http://hdd.tomsk.ru/file/tkqisgxk
10 - 10.07.2015 - 11:00
Обновление 15q2003 от 09.07.2015 г.
Исправили в 1С много чего - список файлов, с датой большей, чем 30.06.2015г (Обновление 15q2002 от 30.06.2015 г.)

FRM1.ERT
FRM1_MP.ERT
NDPI1504.ERT
NDPI1505.ERT
NDPI1507.ERT
NDPI1503.ERT
FSS4_1501.ERT
RSV1_1501.ERT
RSV1_1502.ERT
RSV1_1503.ERT
RSV1_1504.ERT
RSV1_1505.ERT
RSV1_1506.ERT
RSV1_1507.ERT
RSV1_1508.ERT
RSV1_1509.ERT
RSV1_1510.ERT
RSV1_1511.ERT
NDPI1508.ERT
RPLIST_U.TXT
RPLIST_T.TXT
EXTDICT.ERT
NDPI1501.ERT
NDPI1502.ERT
NDPI1506.ERT
NDPI_KOL_PI.ERT
NDPI_LIC.ERT
NDPI_R3.ERT
11 - 13.07.2015 - 04:33
однако в РСВ ещё достаточно багов осталось, в частности в сведениях о стаже период стажа по прежнему первый квартал.
Гость
12 - 13.07.2015 - 13:28


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены