К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

1С: Предприятие 7.7: не выгружается аванс на имущество

Гость
0 - 22.07.2013 - 10:52
Программа комплексная 527 релиз. Пишет

В Разделе 1 найден ОКАТО........которого нет в Разделе 2 и нет в Разделе 3



1 - 22.07.2013 - 11:01
ответ в вопросе... какой ОКАТО у юрика и какой у имущества его?
Гость
2 - 22.07.2013 - 11:07
(1) У юрика 11111111111, в отчете такое же ставлю. А где для имущества задается??
3 - 22.07.2013 - 11:33
эээ... а вы случаем не декларацию пытаетесь выгрузить? а то у мну тоже шум подняли, что имущество не выгружается, а выяснилось, что сохранили авансы, а выгружать пытались декларацию... ЗЫ: и зачем вообще годовую декларацию в квартальную отчетность запихнули?
Гость
4 - 22.07.2013 - 11:33
Вот здесь вылетает, хотя раздел 1 сохраняла

//Берем сохраненные данные Раздела 1, выбираем ОКАТО и проверяем входит оно в таблицу ТД_23 с ОКАТО или нет.
МаскаПоиска = Лев(Строка(Дата2), 2) + Сред(Строка(Дата2), 4, 2) + "02"+НомерВариантаОтчета;
СпВнДанных = ""; СпВнДанных = ПолучитьВнешниеДанные(МаскаПоиска,"ДанныеМнЧ","");
Если ТипЗначенияСтр(СпВнДанных) = "СписокЗначений" Тогда
СпГрупп = СпВнДанных.Получить("П0000100000");
Для i = 1 По СпГрупп.РазмерСписка() Цикл
ТекСтр = СпГрупп.ПолучитьЗначение(i);
ОКАТО_Р1 = ТекСтр.Получить("ОКАТО");
КБК_Р1 = ТекСтр.Получить("КБК");
Если (ПустоеЗначение(ОКАТО_Р1)=0) и (ПустоеЗначение(КБК_Р1)=0) Тогда
ОКАТО_Р1_КБК_Р1=СокрЛП(ОКАТО_Р1)+СокрЛП(КБК_Р1 );
Стр0=0;
Если ТД_23.НайтиЗначение(ОКАТО_Р1_КБК_Р1,Стр0,"ОКАТОКБК ")=1 Тогда
ТД_23.УстановитьЗначение(Стр0,"Вхождение",ТД_23.По лучитьЗначение(Стр0,"Вхождение")+1);
Иначе
Сообщить("В Разделе 1 найден ОКАТО ="+ОКАТО_Р1+", которого нет в Разделе 2 и нет в Разделе 3.", "!!");
ЗаполненностьРеквизитов=0;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЕсли;
Гость
5 - 22.07.2013 - 11:35
нет, смотрю авансовый отчет nimavp1.ert
6 - 22.07.2013 - 11:49
ну как, выгрузилось что-нибудь?
Гость
7 - 22.07.2013 - 12:43
В комплексной 7.7 нет, а у вас Бухгалтерия 7.7 ? Может там нормально написали. У меня нет отчетов для бухии.
8 - 22.07.2013 - 12:51
7-flower > да отчетность вроде единая для ОСН... РУ не может так влиять. советую, прежде чем копать в коде, нажать "восстановить исходный список" и проверить сохраненные варианты в "обслуживание сохраненных данных отчетности". да и сами данные еще раз и галочку/период при выгрузке
Гость
9 - 22.07.2013 - 12:55
(8) я нашла в чем дело !!!!
Если ВидИмущ23 = "1" Тогда
ТД_23.КБК = "18210602020021000110";
ИначеЕсли (ВидИмущ23 = "2") или (ВидИмущ23 = "3" ) или (ВидИмущ23 = "5" ) Тогда
ТД_23.КБК = "18210602010021000110";
КонецЕсли;
У меня вид имущества =3, а КБК бухша выбирает
18210602020021000110 (( Что такое ВидИмущ=3??
10 - 22.07.2013 - 13:03
9-flower > там список есть "3 - во всех остальных случаях". и для КБК тоже выбор. у вас "входящее в единую систему газоснабжения"?
Гость
11 - 22.07.2013 - 13:07
Да, а где поставить ВидИмущ=1
12 - 22.07.2013 - 13:09
11-flower > "код вида имущества" во 2-м разделе
Гость
13 - 22.07.2013 - 13:20
Найдены сохраненные данные одновременно по двум разделам: Раздел 2 и Раздел 3.

Как теперь удалить 3 раздел??
14 - 22.07.2013 - 13:24
13-flower > через "обслуживание сохраненных... "
Гость
15 - 22.07.2013 - 13:30
(14) :))) Спасибо большое.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены