К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

1С 8.2 УТ 2.2 - ошибка при попытке открыть отчет "Реестр документов"

Гость
0 - 17.06.2015 - 22:25
Доброго времени суток! Пользователь что-то не так задал в настройках отчета "Реестр документов", и теперь при попытке открыть отчет под этим пользователем появляется ошибка:
{Отчет.РеестрДокументов.Форма.ФормаЗаполнения(1272 )**: Значение не является значением объектного типа (Отбор)
Для Каждого Строка Из СохраненныеНастройки.Отбор Цикл

и форма отчета закрывается.
Подскажите пожалуйста, как исправить данную ситуацию.



1 - 17.06.2015 - 22:35
Сбрось СохраненныеНастройки
Гость
2 - 17.06.2015 - 22:37
(1)они в каком-то отдельном диалоге находятся? ведь в сам отчет я зайти не могу. сохраненные настройки всех отчетов открываются в другом диалоге?
Гость
3 - 17.06.2015 - 22:50
+(2)в Регистре сведений "Сохраненные настройки" записи для отчета "Реестр документов" отсутствуют, почему-то они в этот регистр не попадают, для теста добавил сейчас под другим пользователем в отчете "Реестр документов" новую настройку, сохранил ее, а в регистре запись так и не появилась
Гость
4 - 18.06.2015 - 09:40
в справочнике посмотри
Гость
5 - 18.06.2015 - 23:05
(4)справочника нет, в модуле выглядит следующим образом
Процедура ПослеВосстановленияЗначений()

Отбор.Очистить();

Для Каждого Строка Из СохраненныеНастройки.Отбор Цикл
НоваяСтрока = Отбор.Добавить();
Для Каждого Кол Из Отбор.Колонки Цикл
НоваяСтрока[Отбор.Колонки.Индекс(Кол)] = Строка[Отбор.Колонки.Индекс(Кол)];
КонецЦикла;
КонецЦикла;

// Остальные реквизиты отчета сохраняются стандартно
КонецПроцедуры
Гость
6 - 18.06.2015 - 23:13
ну закомментируй, сохрани новые настройки, верни как было
Гость
7 - 19.06.2015 - 07:53
(6)да, именно этот способ помог, спасибо большое! что-же это было?
Гость
8 - 19.06.2015 - 08:01
(7)Что не так сделал пользователь? Или это 1С настройки криво сохранила?


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены