К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Помощь в ЕхсеL

Гость
0 - 16.01.2013 - 12:20
Добрый день!

Расскажите как в Excel скопировать данные с одной таблице в другую, чтобы остатки копировались по наименованию.



Гость
1 - 16.01.2013 - 12:45
"...чтобы остатки копировались по наименованию..." - что это значит?

Если в Табл1:
Яблоко 1
Банан 5
Груша 4

А Табл2:
Яблоко 6
Груша 10

И нужно получить такое
Яблоко 1 6
Банан 5 0
Груша 4 10

то это делается функцией вида

=ВПР(A1;Таблица2!$A$1:$B$3;2;ЛОЖЬ)

которая найдет совпадение наименований в двух таблицах, а затем вернет из второго столбца второй таблицы "остаток", т.е. число
Гость
2 - 16.01.2013 - 12:52
Естественно, раз во второй таблице нет слова Банан, то функция ВПР вернет ошибку #Н/Д (нет таких данных), что можно считать нулевым значением (можно автоматом-формулой вставить 0).

Однако такая же ошибка будет и в тех случаях, когда вроде бы одинаковое наименование содержит невидимые начальные или конечные пробелы - если таблицы правились ручками.

Рекомендуется перед написанием ВПР взять сделать рядом столбец с формулой =СЖПРОБЕЛЫ(A1) и протянуть его на весь диапазон, и ВПР-ом ссылаться уже на него. А если таблицы взяты, скажем из 1С и ручками не правились, то об этом можно не беспокоиться.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены