К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Генератор Excel

Гость
0 - 21.11.2012 - 21:16
Здравствуйте уважаемые форумчане. У меня следующий вопрос: возможно ли сгенерировать автозаполнение таблицы эксель (версия 2007) из какой-нибудь другой таблицы эксель (там вроде хранилища с разными вариантами для каждого поля). Пример тут http://www.onlinedisk.ru/file/985329/ В общем чтобы при нажатии на кнопку "генерация" из листа "Хранилище" в лист "Режим" попадали адекватные данные в соответствующие поля.


Гость
1 - 21.11.2012 - 21:41
Расскажите как данные сопоставляются - подскажем макрос. Также это делают функции ВПР, БДИЗВЛЕЧЬ ИНДЕКС ПРОСМОТР и др.
Гость
2 - 22.11.2012 - 07:45
Если лист Хранилище содержит данные о часах и ЗП

Иванов 165 55 тыс. руб.
Петров 120 34 тыс. руб.
Сидоров 14 2 тыс. руб.

А на листе Режим нужно увидеть
Данные в виде только
ФИО, ЗП, Часы (другой порядок столбцов) и без Сидорова
то это решается созданием на листе Режим шапки и таблицы с нужными заголовками столбцов (ФИО, ЗП) и строк (сами НУЖНЫЕ фио, сверху вниз) и ввводом ОДНОЙ формулы в одну ячейку В2 на листе Режим, которую можно просто скопировать во все остальные, протягиванием рамки:

=ВПР($A2;Хранилище!$A$2:$C$65535;3;ЛОЖЬ)

Чтобы не вводить номер столбца (число 3) - можно пронумеровать в служебной строке (например в строке 10) листа Режим столбцы произвольно, и формулой сослаться на них (1,2,3 -> 1,3,2)

=ВПР($A2;Хранилище!$A$2:$C$65535;A$10;ЛОЖЬ)

Даже если Хранилище - это отдельный XLS-файл - можно сослаться на него, и тогда при открытии файла Режим - будет выдан запрос на получение данных из Хранилища. Т.е. какие либо кнопки - излишни.


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены