К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

Excell функция вычисления пересекающихся дат из нескольких диапазонов

Гость
0 - 13.02.2014 - 10:52
В общем есть такая задача
с\х предприятие, есть два трактора, они могут выполнять разные работы
есть даты этих работ
мне надо вычислить нужны ли в этом году новые трактора? при условии что один трактор может выполнять только один вид работы в день

пример:
вид работы №1 с 01.01.14 по 01.02.14
вид работы №2 с 02.01.14 по 02.02.14
вид работы №3 с 03.01.14 по 03.02.14

т.е. с 03.01.14 по 01.02.14 будет одновременно выполняться три вида работ, а значит нужен еще трактор

как это посчитать в экселе если уже есть таблица с исходными данными (столбцы):
1. вид работ
2. дата начала
3. дата окончания
4. модель трактора



Гость
1 - 13.02.2014 - 12:40
Есть такая диаграмма - диаграмма ганта вот на ней будут видны пересечения.

Я бы отсортировал данные по модели трактора с датой начала и затем для каждой модели построил бы диаграмму ганта.
Если делать таким http://www.youtube.com/watch?v=1UISGNLYFpU образом то нужна еще колонка с длительностью ее можно посчитать как разность дат
Гость
2 - 13.02.2014 - 12:42
Наложить фильтр и отобрать по дате. Если в столбце оказались 2 трактора знач они пересекаются. не?
Гость
3 - 13.02.2014 - 13:06
1-ipp > благодарю!
Гость
4 - 13.02.2014 - 13:28
Да еще после сортировки по модели трактора с датой начала работ можно рассчитать пересечения работ как разность даты начало текущей работы минус дату конца предыдущей работы и вот где эта разность меньше 0 там и есть пересчение
Гость
5 - 17.02.2014 - 08:44
Важно понимать, что истинные даты для Excel - это простые числа. Например 01/01/2001 - это 36892. Следовательно, если у вас истинные даты - то их можно легко сравнивать. Входимость даты в интервал легко найти:

01.01.2014 01.02.2014 15.01.2014
=И(C1>A1;C1<B1) даст ИСТИНА, потому что 15/01 - входит.
Гость
6 - 17.02.2014 - 09:02
5-economist > дело в том, что мне надо выяснить кроме самого факта "наложения" одного вида работа на другое, надо еще знать сколько этих "наложений" ведь может такое быть что будет 3-4 вида работ в день, а значит потребуется дополнительное не 1 а 2 или 3 трактора.
спасибо
Гость
7 - 17.02.2014 - 09:05
4-ipp > что-то у меня какая то фигня с графиком, почему то мои начальные даты для графика являются конечными датами, а когда добавляю какое то число, то добавляется ко всем "столбикам" диаграммы одновременно
продолжаю воевать, спасибо
Гость
8 - 17.02.2014 - 09:40
всем спасибо, победил!
Гость
9 - 18.02.2014 - 14:18
JMin - количество "наложений"определяется простым суммированием. Однако суммировать логические значения ЛОЖЬ ИСТИНА нельзя. Нужно формулу изложить так:

=ЕСЛИ(И(C1>A1;C1<B1);1;0)


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены