К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

расшифровка в СКД самая простая самая обыкновенная - не хочет работать, почему это может быть?

med
0 - 01.10.2012 - 10:34
УПП Самый обычный отчет о денежках
Подразделение организации - Статья расходов - Денежная (Бюджетная) операция - Выполненая Заявка на денежные средства
Формируется таблица значений
передается в СКД
Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;
МакетОформления = ПолучитьМакет("МакетОформления");
КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки,ДанныеРасшифровки,МакетОформления);
ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновки.Инициализировать(МакетКомпонов ки,Новый Структура("Отчет", Отчет) ,ДанныеРасшифровки);
ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновкиДанных.Инициализировать(МакетКо мпоновки,ВнешниеНаборыДанных);
ТабДокН = Новый ТабличныйДокумент;
ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличны йДокумент;
ПроцессорВывода.УстановитьДокумент(ЭлементыФормы.Р езультат);
ПроцессорВывода.НачатьВывод();
Пока Истина Цикл
ЭлементРезультата = ПроцессорКомпоновки.Следующий();
Если ЭлементРезультата = Неопределено Тогда
Прервать;
Иначе
ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
КонецЕсли;
КонецЦикла;
ПроцессорВывода.ЗакончитьВывод();
УправлениеОтчетами.УстановитьКолонтитулыПоУмолчани ю(ЭлементыФормы.Результат, КомпоновщикНастроек.Настройки.ПараметрыВывода.Элем енты.Найти("Title"), Строка(глЗначениеПеременной("глТекущийПользователь ")));
ЭлементыФормы.Результат.ТолькоПросмотр=Истина;

Надо сделать расшифровку самую обычную из 1 действия "Открыть"
Делаю штатно

Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
Перем ВыполненноеДействие;
СтандартнаяОбработка=Ложь;
ОбработкаРасшифровки=Новый ОбработкаРасшифровкиКомпоновкиДанных(ДанныеРасшифр овки,Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКом поновкиДанных));
ДоступныеДействия=Новый Массив;
ДоступныеДействия.Добавить(ДействиеОбработкиРасшиф ровкиКомпоновкиДанных.ОткрытьЗначение);
Настройки=ОбработкаРасшифровки.Выполнить(Расшифров ка,ВыполненноеДействие,ДоступныеДействия);
Если Настройки<>Неопределено Тогда
КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);
ЭлементыФормы.Результат.Очистить();
СкомпоноватьРезультат(ЭлементыФормы.Результат,Данн ыеРасшифровки);
КонецЕсли;
КонецПроцедуры

Когда щщелкаю на
Подразделение организации
Статья расходов
Денежная (Бюджетная) операция
Всё прекрасно открывается
когда щщелкаю на
Выполненая Заявка на денежные средства - результат нулевой никакой реакции - типа для нее нет доступных действий в чем может быть проблема ?
Думал в таком случае написать сам процедуру открытия данного документа, но не могу разобраться, как получить значение из данного поля - расшифровка возвращает какие то цифры "122", "146" и т.д.
Как получить открытие всех полей или как получить значение из данного поля ?



1 - 01.10.2012 - 11:04
значение из данного поля ты и получаешь: "какие то цифры" это индекс элемента расшифровки
med
2 - 01.10.2012 - 12:18
1-roma n > Да так его и зовут, только вот какой командой/функцией из этого индекса получить просто значение ?
3 - 01.10.2012 - 13:45
это индекс => получаем по индексу из коллекции элементов данных расшифровки.
ЭлементРасшифровки = ДанныеРасшифровки.Элементы[Расшифровка];
У элемента расшифровки есть методы ПолучитьПоля(); ПолучитьРодителей()
med
4 - 01.10.2012 - 13:50
Спасибо, попробую
med
5 - 03.10.2012 - 13:33
Хотя вопрос - почему она не работает штатно остается открытым


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены