К списку форумов К списку тем
Регистрация    Правила    Главная форума    Поиск   
Имя: Пароль:
Рекомендовать в новости

На редкость не лепая проблема. Обращение в модульОбьекта из модуляФормы. Упр прил. А не хочет... Я в шоке

Гость
0 - 05.06.2014 - 23:56
И так, есть процедура в модуле формы.

&НаКлиенте
Процедура Реквизит1ПриИзменении(Элемент)
а=0;
ПроцедураНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПроцедураНаСервере()
ТестоваяПроцедураАМодулеОбъекта();
Справочники.ТестовыйСправочник.ТестоваяПроцедураМо дулеМенеджера();
КонецПроцедуры


Ну и в МодулеОбъекта:
&НаСервере
Процедура ТестоваяПроцедураВМодулеМенеджера() Экспорт
б = 0;
КонецПроцедуры

И МодулеМенеджера:
Процедура ТестоваяПроцедураМодулеМенеджера() Экспорт
б = 0;
КонецПроцедуры

---------------
Управляемое приложение, релиз меняли на самый последний....

Результат:
{Справочник.ТестовыйСправочник.Форма.ФормаЭлемента .Форма(10,2)**: Процедура или функция с указанным именем не определена (ТестоваяПроцедураАМодулеОбъекта)
<<?>>ТестоваяПроцедураАМодулеОбъекта(); (Проверка: Сервер)



Гость
1 - 06.06.2014 - 00:01
Не работает обращение в МодульОбъекта. Просто по имени процедуры. Или я что то пропустил?
Предположения:
1) 1с считает, что МодульОбъекта лишь для процедур движений. Не фиг туда глобальные для справочника процедуры ставить.
Гость
2 - 06.06.2014 - 00:09
Предположение еще:

2) Все должно лежать в глобальном модуле....
Гость
3 - 06.06.2014 - 00:16
Ты все пропустил. Это расширения обычных форм для объектных типов поставляли возможность использования экспортных методов самого объекта. Расширения управляемых форм для объектных типов этого никогда и не умели.
Гость
4 - 06.06.2014 - 00:20
Как...Всегда обращение к процедура в модуле объекта было просто по именно.....
Гость
5 - 06.06.2014 - 00:20
А...то есть в обычном приложении работало, в управляемом уже нет? Тогда понятно.
Гость
6 - 06.06.2014 - 01:08
5-Сергей2 > Ну да, "трехзвенка" из модульного разделения превратилась в связку трех совсем-совсем отдельных компонент.
Которые могут проживать в трех разных местах.
Гость
7 - 06.06.2014 - 01:28
понятно, спасибо. а то аж мозг закипел
8 - 06.06.2014 - 06:28
Полу ОФФ: Чтение СП немножко охлаждает ))


К списку вопросов
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск




Copyright ©, Все права защищены