Показать сообщение отдельно
Гость
- 21.02.2018 - 15:10
вот держи

если нужно сразу на печать без показа окна, то можно без фокусов в ПриЗакрытии, просто из формулы напрямую нельзя открывать окна


Перем таб;
Перем можноЗакрыть;

Процедура ПриИзменении()
таб.ВывестиСекцию("111");
можноЗакрыть = 0;
Форма.Закрыть();
КонецПроцедуры

Процедура ПриОткрытии()
таб = СоздатьОбъект("Таблица");
таб.ИсходнаяТаблица("Таблица111");
КонецПроцедуры

Процедура ПриЗакрытии()
Если можноЗакрыть = 0 Тогда
можноЗакрыть = 1;
таб.Показать();
Активизировать("ПолеВвода",0);
СтатусВозврата(0);
Возврат;
КонецЕсли;
КонецПроцедуры

можноЗакрыть = 1;